Kaseya Community

Set Credentials Failing

  • I am trying to set credentials for an agent but the continually fail.

    • Kaseya VSA 9.5
    • Agent
    • Windows 10 Pro 1809

    We have 280 agents in our Kaseya environment and 99% of them use the same AD account for the credentials. This is a service-only account so cannot be used for interactive logins. This account has worked previously for the workstation in question but after problems installing Acronis were resolved with a manual installation, the credentials have been failing and I have had to set Acronis to back up on a local schedule as the machine cannot be managed via the VSA. Everything else Kaseya-related seems to be working okay and the account is working fine for other Kaseya agents.

    I found this KB article (https://helpdesk.kaseya.com/hc/en-gb/articles/229011628-Set-Credential-test-fails-despite-entering-valid-credentials) but the solution is already in place.

    Kaseya Support seem to be baffled by this so far.

  • We are also experiencing the same thing only we are Windows 10 Enterprise 1803 and not using Acronis.

  • Turning Windows DEP off (www.online-tech-tips.com/.../disable-turn-off-dep-windows) and testing has allowed the credentials to authenticate, however, DEP is a security feature and should not be left off.

    I have enabled DEP and tested the credentials again and now they are authenticating fine...

    Go figure...

    [edited by: DCA-RichM at 5:52 AM (GMT -8) on Nov 20, 2018]
  • Hi James, try the command-line DEP solution mentioned above.

    [edited by: DCA-RichM at 6:45 AM (GMT -8) on Nov 20, 2018]
  • I had a problem like this before. I was told to check "Specify Domain" on the Set Agent Credentials page and Specify the domain name. That worked for me. I have not had the issue with the latest patch though.