The problem is that there are at least 5 versions of dotnet to be installed. A profile setup with each of the latest major revisions. The latest major revision being 4.6.01055. With all of the rest installed as well, they then report as being different between installed and profile version, resulting in red exclamation points.

This affects our policy management as well since the reported installed versions do not meet the ksdu profile versions.

Is there a way to rectify or reconcile between the two versions or hold the previous dotnet versions to their originally reported versions?