Kaseya Community

KSDU catalog out of date

  • https://ninite.com/news tells that Java 8 updated to 8u66-b18 (November 19) but our catalog only shows that latest version available is 8.0.600.27 for 32bit. 64bit is okay, 8.0.660.18. Any ideas why? Customer is worried.

    This did not help:

    https://helpdesk.kaseya.com/entries/105290866-KSDU-Master-Catalog-does-not-have-the-latest-version-of-software-available-with-ninite


    So I guess contacting support is the next step.



    KB article
    [edited by: neuvoja at 3:41 AM (GMT -8) on Nov 24, 2015]
  • Make sure that you set the application to "Always deploy latest". If this is not set it will use what you have in your catalog only and not add new versions. To fix it quickly remove and add Java to the profile again and make sure you set it to "Always deploy latest".

  • I removed Java 8 from a profile and when trying to add it back, it gives error that it's already in a profile which is associated to machine.

    Deleting the profile is not an option as we use policy mgmt to deploy, I'd have to add the "new profile" to every customers KSDU policy. I  did this when Flash was not updating to latest version and it was not fun at all :)

  • Sounds like you have several profiles applied to the same machine/machine group. I guess you have checked that?

    Do you have a screen dump for one computer? Status / By Machine and Profiles / Assign By Machine.

    From my experience it should not be necessary to create a new profile....

  • Indeed that could be the case, I tested this with two new profiles and the error did not appear. We use two profiles: one that only updates if the software is already installed and the other always installs/updates the software. I will have to check the policies in pol.mgmt. if these two are applied into the same policy.

  • Yup, one customer had both profiles assigned via pol. mgmt.

    Still our catalog is out of date (java 8, Flash, Adobe Reader DC) , hoping that support will find a fix.

  • You could always update the catalog manually by drag/drop from Master Catalog. After that remove/add the application from the profile(s) and make sure you set it to "Always deploy latest". This way it will update to the latest version in the future and download to your catalog.

  • I tried that, no change.

    Success! I managed to manually add them to the sw catalog using the Add Master Catalog Installer option. I hope this was one of kind bug and not something that keeps happening all the time :)



    Success!
    [edited by: neuvoja at 7:03 AM (GMT -8) on Nov 25, 2015]