Kaseya Community

Can't use Lan Cache?!

  • Am I right that we can't use Lan Cache for distribution of Software Deployment files?

    Thanks!

  • That is true. KSDU has it's own version of LAN Cache. They have received a feature request to merge them and from what I heard in April that was still part of the plan.

  • If you do not enable KSDU's File Source and have the LAN Cache configured, the VSA will use the LAN Cache machine to distribute the Software Deployment files.

  • I've writted Support and will veryify this.

  • Tim,

    That is not the case from what we have seen in the field nor does it correlate with any discussions I had at last years Kaseya Connect. So, unless there have been changes made that I have missed in the release notes, it's still working as I've described.

  • Hi Matt,

    I went ahead and did a test KSDU deployment with a LAN Cached enabled machine and saw the KSDU installers get pushed to the LAN Cache folder. What I would recommend if this is not the behavior you are seeing is to double check if "Write File" is the option you use to push out deployments. This can be verified by going to KSDU > Application Settings > General Settings > Edit. If you are in our cloud offering, we force the usage of downloading the installer through a URL, only if you do not use KSDU's FIle Source, and that could prevent LAN Cache from obtaining the file. This is because LAN Cache works when you (or a system script behind the scenes) uses the WriteFile step.

    I was one of the personnel at the Kaseya Connect conference last year and would have gladly walked you through this. I do apologize if we missed each other to discuss this further in person.

    If you need more information on this topic, feel free to let me know and I can provide more details if needed.

  • Hi Tim,

    Thanks for the answer above. It's a bit confusing in its wording though...

    When you say " If you are in our cloud offering, we force the usage of downloading the installer through a URL", are you saying that on hosted Kaseya LanCache will NOT work for KSDU, only File Source?

    Hoping this isn't the case. I'm so tired of being penalized for being in the cloud.

  • Hi Interprom,

    This is more of a benefit to most cloud users rather than being penalized. The URL option helps because it pushes the KSDU installers from our specific KSDU Cloud servers to the agents directly.

    In an On-Premise solution, the installer will go from the KSDU Cloud to the On-Premise server, assuming this is the first time the installer is being used. If a LAN Cache (or KSDU File Server) is involved, the installer will then go from the On-Premise server to the LAN Cache (or KSDU File Server) endpoint and then finally the target agent(s).

    In a Cloud solution, the installer goes directly from the KSDU Cloud to the target agent(s). If there is a KSDU File Source configured then it will go from KSDU Cloud to KSDU File Server endpoint then finally to the target agent(s).

    In the Cloud, the KSDU File Server has the capability to acknowledge and use the KSDU Cloud Servers to obtain the installers needed for that environment whereas natively LAN Cache does not and in an On-Premise environment, LAN Cache relies on the On-Premise Server to handle the installers first before obtaining them causing more hops for the installer to get to the target endpoint.

    I hope that helps in understanding the current flow. Of course this can be subject to change in the future through product enhancements.

  • We will test this further.

    As I recall, after the Quick Start course on Sat and Sun, this was discussed specific to our configuration. We had a discussion with the person at the KSDU demo and he reiterated that it was not configured to use LAN Cache at that time.

    We are On-Prem with a fresh environment running R8. I'll have my team go through these suggested settings and see if we can verify that it works or let you know the error we are seeing. After then, we can open a ticket if you think there is something not working properly.

    Thanks Tim!