Kaseya Community

Effective Policies empty?

  • patch .23 resolved this for me although I did do a reinstall of the application to resolve a software management issue so it may have been this which corrected the issue

  • Effective policies are still blank for us after patch .24;

    Any newly created agent present in a machine group that has policies present, never receives the policies.

    policy -> machines -> select machine shows a 'no policy' icon, clicking that icon opens a pop-up; the popup shows nothing under policy object status details (only n/a in every column) and machine effective policy settings returns 'no records found;.

    if we check the tick-box next to the agent and click 'reprocess policies', everything comes god immediately (policy icon shows green dot, all policies applied correctly as expected).

    So, none of the patches have fixed it for us.

  • Hello Craig,

    In 9.3 we don't have this problem. All the policys are appleid correctly without any problems.

  • ,

    For this issue:

    "Any newly created agent present in a machine group that has policies present, never receives the policies."

    Try this:

    Navigate to Policy > Settings

    Change the deployment interval from whatever it is now to some other value

    Click Save

    Change the deployment interval from the new value back to the value you want (but NOT 'manual')

    Click Save

    Next time agents are added, check to see if the appropriate policies are automatically assigned.

    As a note, there is a backend process which runs once per hour to assign policies on View membership changes (you edit a view used in a policy and agents are then added to/removed from that view).  Depending on where in the cycle this background process is, it might be a while before you see the correct policies associated with the machines, but the appropriate policies should automatically assign and be visible for the machine(s) within no more than an hour or so.  This is separate from the deployment interval.  You can force this to occur faster by selecting the agents and clicking the "reprocess policies" button.


  • And then go to System > Outbound email and enable it and Service Desk > Incoming Email and enable your email readers. Changing the policy deployment interval disables both of things and seems to stop KSD from processing any alarm into a ticket until re-enabled.



    Typo
    [edited by: JB1975 at 12:01 AM (GMT -7) on Jul 26, 2017]