Kaseya Community

Making a View that EXCLUDES all Virtual Servers (VMware and Hyper-V)

This question is not answered

Has anyone had any success in creating a view that only contains physical Servers?

I have made one that excludes VMware virtual machines (missing application vmtoolsd.exe) but have not been able to have in the SAME view MS Hyper-V VM's.  I know that for Hper-V the Product Name is "Virtual Machine" but unable to add that to the view that already excludes showing servers without vmtoolsd.exe.


Aside from that, the View creation is buggy - if I make a change to the view, save it, and then remove the change, save it, I get different results.  I have to throw the view away and start again.

All Replies
  • In the "Advanced agent data filter" settings, set the product to "NOT *Virtual*"

    This works for both hyperV and esx

  • Thanks Eddy.  I swore I tried that yesterday, but it didn't work and went back to showing all servers.  Just tried again, and it worked.  crazy  :-)

  • I find that when editing a view and saving it, it doesn't apply straight away. You have to select a different view, then select the view you want once more, in order for the grids to update.