Kaseya Community

Policy Management no longer deploying settings

This question is not answered

A couple of weeks ago we installed hotfixes and did a schema replace on our K6.3 environment, from that day forward Policy Management stopped deploying settings to agents.

Agents appear in the correct views no problem.

Policies can be correctly associated with orgs, machine groups and individual machines with no issues.

However, no settings are ever deployed to any agents.

We've tried everything, new policies, clear overrides, re-process policies, hotfix and schema replace, server restarts ........... nothing we've tried so far will get policy management working again.

And now, this morning, we've lost our first client as a result. 2 of their new servers had issues last week and we had no alerts. This client had over 500 agents with us, so there's some really angry people around here. The client deploys their own agents, so we didn't even know the agents had been added !

I suggested setting up a new server and migrating the agents to it, but thats been rejected as an idea. Other than that, I'm out of ideas.

Anyone ?

All Replies
  • James,

    I would suggest you verify that the Deployment Interval is configured to something other than Manual if there are no settings being deployed (Policy > Settings).  If some but not all are being deployed, ensure you have all hotfixes (System > Configure > Get Latest Hotfix) and reprocess policies on any endpoints that do not have the configurations you'd expect (particularly in any case where the policy deployment icon on the Policy > Machines page is not "in compliance").  If those don't resolve the issues, I would encourage you to open a ticket with support, if you have not done so already, so the issue can be further investigated.

  • Thanks Brande,

    I've changed the deployment interval a few times, and have also reset the compliance schedule. Neither have made a difference. Have just done it again this morning. Set deployment at 5 minutes.

    There is no such thin as "in-compliance" in our system. All agents show as "no policy" even though many machines have had a policy manually assigned at a machine level.

    We logged an urgent ticket 11 days ago, nothing so far. I believe its been escalated to development so not expecting any miracles.

    Does anyone know what the server side process is that runs to distribute associated policy settings to agents ? ..... is this something that could be manually run on the server to get us back up and running ?

    Thanks

  • i have this same issue i know this thread is years old but i have it in the latest version avail today