Kaseya Community

Alert when this event occurs X times within X hours

  • If I add an alert event and want to select 'Alert when this event occurs X times within X hours' it applies successfully. If I hover over the alert it is showing the correct setting.

    However, if I check the actual alert settings under Monitor / Event Log Alerts after applying the policy, it shows the number of times but it shows 0 days. I am not sure if the alert setting is working or not. It is my understanding that what you see under Event Log Alerts is the correct setting.

    Is anybody else seeing this?

  • Yes, I am seeing this as well.

  • Expanding on this; No matter what value I put in the X Mins/Hours/Day field, it always shows as 0 when reviewing the settings on the Monitor tab. Also, it always appear to say "0 day" rather than what the setting was set as in the policy. For instance, my test policy now have an event log alert define as such:

    "Alert when this event occurs 4 time(s) within 2 Hr, ignore additional alarms for 4 Hr"

    When reviewing the setting in Monitor -> Event log Alerts, it says:

    "Alert when this event occurs 4 time(s) within 0 Day, ignore addition alarms for 4 Hr".

    I have submitted a ticket with Kaseya, hopefully, we can get this cleared up.

  • I had the same results. I have also submitted a ticket and they have escalated after testing. Hopefully it will be resolved soon. I am assuming that this alert does not work since 0 Days is not a valid time frame.

  • My ticket has been escalated to a "specialist" ...

  • This is good to know. I thought I was going crazy! Let me know how you guys get on.

  • Kaseya has acknowledged the issue, and are working (or will be) on a hotfix to resolve the matter. No ETA on when the hotfix will be available. Hopefully soon.

  • Any updates on a hotfix for this?

  • Email me the ticket for this and I will follow up on the status.

  • This has been resolved with the latest hotfix. It works as designed.

  • Indeed it does appear to have been fixed. Thank you for checking in on that :)