Kaseya Community

Policy Management: Policies not applying

This question is not answered

Please let me know what I'm doing wrong here. I've followed the documentation provided here and it just isn't working.

 

I created a policy, created my desired settings and assigned it to a view. I found a machine in the organization/machine group "unnamed.root" (just for testing) which can be located using the same view on which the polices are based. I assigned those policies to the organization/machine group "unnamed". The scrolls are white indicating I've saved and applied the policies. Nothing happens. What step did I miss here? Even if I manually assign the policy to the machine it doesn't actually apply. The icon next to the machine indicates nothing is applied to it.

All Replies
  • I agree with Bump, the purpose with Policy management should be more automation less manual work, and the most important thing you should be able to trust it! We also have similiar problems that you have described.

    A policy should be on top of everything you do in Kaseya, All settings , procedures etc should be overwritten by the Policy´s settings procedures etc. And I should be able to trust that it does what´s it´s supposed to do, not manually have to clear override, apply policy again etc etc. That´s not a Policy in my eyes.

  • Bump
    Doing what ghetto mentioned works, but why do I have to do this? Why are machines magically falling out of policy to begin with?

    When Policy Mgmt was first released, we had some issues where policy settings were not being applied correctly.  Last year, a number of hotfixes were released to address all of the known issues.  At this time, when we get a ticket reporting that policy settings are not applied properly, it usually turns out to be one of two things:

    a) a machine's view membership has changed, so the originaly policy settings have been replaced by policy settings associated with the latest set of views that the machine belongs to

    b) someone (perhaps a different person from the one who manages the policies) has manually changed (i.e. 'overriden') the machine settings after the policies were applied.  Policy Management is designed to track and accept these overrides.  It also allows you to clear the overrides as mentioned earlier in this thread.

    If you have a repeatable scenario where policy settings are not in effect, and it is not due to either of theses two conditions, please submit a ticket with the details of a machine that is exhibiting the problem.  We would like to work with you to get to the bottom of it...

    Thanks,

    Kevin

  • Hi,

    The machines had not moved between views and the views have not changed so this is definitely not the cause in my situation.

    We're an Enterprise customer and I'm typically the only user ever in Kaseya to be completely honest. No others have changed these settings and the end user had no ability to do this either. For example, our Patch Scan schedule just disappears from machines on occasion.

  • our Patch Scan schedule just disappears from machines on occasion.

     

    this happens to us too

  • @Bump & @Michael

    We'd very much like to get to the bottom of this.  The next time it happens, please submit a support ticket with details of the names of the policies and the machines that are losing settings.

  • See ticket: CS094670

  • let us know how you get on bump . i stopped using pol man for patching there has been to many issues with it so far. will revisit it when things get sorted out more

  • Michael Dixon (enfusion)

    our Patch Scan schedule just disappears from machines on occasion.

     

    this happens to us too

     

     

    I've noticed that my audit schedules disappear from time to time within the policies.

  • They appear to have acknowledged the problem finally and my ticket is in a "Hotfix Review" status.

  • awesome bump

  • Any update on this? I also have the same problem.

  • I found a solution my side. Was very simple and I nearly kicked myself for it.

    Under policy management, go to policy. Create new policy, set what you want to automate then you actually have to click on the root folder or any folder your policies are stored and you will see a "Apply Policy" button. Say Allow scheduler to apply and you can then assign it to a machine group or machine. You need to click that or your policies will fall out of compliance I have found.