Kaseya Community

CIM classes failed/timed out/was aborted

  • Can someone help me resolve what my issue is? I am attempting to use a CIM monitor to monitor raid status on a VMware ESXi 6.0 host. I have created the ready only CIM account on the host and turned on the CIM Server service. I then set the CIM credentials on the top level and inherited down. When I try to create the CIM monitor and rescan for services I get the error below. I do have VMware performance setup and it lists items, so it seems like communication is working?

    The enumeration remote work item for CIM classes failed/timed out/was aborted on device "IP of HOST" port 5989 for user "cim" on CIM namespace "root/cimv2"

    Thanks!

  • Looks like you have the wrong namespace, perhaps.

    blogs.vmware.com/.../hardware-health-monitoring-via-cim-part-5.html

  • I ran a get-ciminstance on my VMware host and it asked for a class name. I tried VMware_Controller but received an error, but looking at the error, it leads me to believe my namespace is in fact root\cimv2. The error was telling me it was an invalid class though.

    I am using the Dell customized ESXi 6.0 image, I tried to do some searching to see if they used a different namespace but didn't find anything.

  • I finally got this to work by giving my CIM account in vSphere administrator privileges.