Kaseya Community

Network Monitor and ESXi

  • We have been using Kaseya since 2006 and I have still not delved into Network Monitor...but the time might have arrived.  We have a need for hardware monitoring of ESXi hosts and it appears this would be the way to go.  Before we spend a bunch of man hours, I was hoping to hear from someone who uses KNM for this to find out if it is a good answer.

    Just as important, if someone has tried to set it up and failed or found a better solution, I would love to hear about it.

    Thanks in advance for whatever insight or feedback you can offer

    Ken

  • Hello Karoded,

    We use KNM(i) to monitoring ESX host with SNMP. We dropt CIM because the result off it can't be modified like SNMP. We don't want result in integer or decimal values.

    @Kaseya, pls fix CIM that we can ValueMap” to “Values” for some of the CIM monitors and not show 5,1,1,1,1 ....

    Beside that we still use the old LUA script for ESX version to monitoring the Health Status.

    If you have question just shoot.

  • Hi ,

    Thanks for the input.  I have been working to set this up but so far unsuccessfully.  We are on VSA 9.3.0.31 and we are trying to Monitor ESXi 6.5.  Using a different tool, I can connect and retrieve data from esxi using SNMP v2c but all my Kaseya monitors return "Cannot retrieve VMWare Web Service host list".  I do find it concerning that Kaseya only appears to know about version 4.x and 5.x...could this be the cause?

    Thanks

    Ken

  •  

    I was able to set up monitoring on esxi 6.5 without an issue.

    Here are the steps I took:

    1. Add credentials (CIM and VMWare):

    Step 2: Press 'Inspect Now':

    That should suggest some pre-configured monitors for you based on the standard ESXi template.

    Here is the results of adding all the suggested monitors:

     _

  • When will Kaseya add the Valuemapping for CIM monitoring. Because we only recieve integer output.

  • Thanks for that Nicolas, I tried the same on one of our VMware servers but after the inspect is ran I can only see the default 4 VMware old lua monitoring sets, how did you get all the different ones you have in green on your picture?

    Many thanks

    Craig

  • I don't see an ESXi template on mine nor any esxi specific lua scripts......is there something additional I need to install or refresh?

    Though I did get basic monitoring going by connecting to the ILO port and using those lua scripts

  •   

    ESX LUA Scripts are no longer provided in out of the box installations, they may be present in legacy/older installations.

    These LUA Scripts were removed as the functionality was built into the product so the LUA scripts, these were originally created before CIM and VMWare Performance Monitors were implemented. As they have been implemented now, they are no longer necessary.

    In regards to a specific template, there is no template in the templates page for ESX, but that is not necessary.

    All that is required is to click "Inspect Now" as per my previous screenshot and it should detect these monitor types automatically.

    If it's not returning any monitors under 'Pre-Configured Monitors, you have a credentials/access/network accessibility issue with the gateway and the ESX server:

    Keep in mind you should have both credential types as shown in my previous post.

    If both credential types are set, the way to validate if you have access to VMWare / CIM Metrics is the following;

    1. Try to add a VMWare Performance Monitor:

    Select 'Add Monitor' - Then try to scan for counters, if nothing shows you have an access issue;

  • Hey guys, I seem to be able to monitor performance, which is great.  But I really would like to monitor at least disk health, and maybe power.  The server I am testing on is a Dell, and the drives do show up under Storage in ESXi, so we have installed the correct *.vib.  I have tried using CIM and cannot seem to get any data to return.

  •  I was able to get CIM monitoring working by choosing the OMC_   Class for the component rather than the CIM_ class.  Though the results are a numeric value that you need to evaluate.  As far as I have seen a return of 5 means everything is OK and anything else (typically 0 or 30) means something is wrong.

    If you are getting nothing, I would check the CIM user you are using and ensure the CIM service is running on ESXi.

    Not for nuthin but this whole KNM really feels very 2005 with how manual and obscure everything is.  I am very surprised more hasn't been developed to make it user friendly.

  • In terms of disk monitoring, there have been several discussions about this and some alternatives/scripts;

    http://community.kaseya.com/xsp/f/159/p/21539/100124.aspx#100124

     -- Do you have a support ticket or an incident to reference?

  • Hi Nicolas

    I have ESXi servers, that I can successfully connect to in Network Monitor, and add the ESXi Health LUA script to, and I get results.  I have added the VMWare root creds to the VMWare and CIM account sections, and then perform an "Inspect Now", but I don't get anything in the Preconfigfured Monitors.

    Do you have any suggestions to try?  Its running ESXi 5.5.

    Thanks

    David

  •  

    If you go to 'Add New Monitor ' > VMWare Performance > 'Rescan Services' does the drop down populate?

  • Hi Nicolas,

    No I get a message:

    Message

    The VMware web service session login failed!

  • Has anyone had this issue?.......

    I have the CIM monitors working but every 5-7 days, they stop and we start getting other problems on the server.  This seems to require a reboot of the host to resolve.  It is running on an HP ProLiant and I did install the VIBs but removed them after this happened the second time.  It just happened again over the weekend.  The error we get on the monitor is

    Cannot execute CIM query or get any property value! ExecQuery reports: "The query "SELECT HealthState FROM OMC_PowerSupply" cannot be executed. Reason: Failed to process HTTP request to /cimom. HTTP Status Code: 0, HTTP Status Message: "Cannot connect TLS socket. Error code = 2148074241.".". EnumerateInstances/GetInstance reports: "The property value for "OMC_PowerSupply.Star.HealthState" cannot be retrieved. Reason: Failed to process HTTP request to /cimom. HTTP Status Code: 0, HTTP Status Message: "Cannot connect TLS socket. Error code = 2148074241.".".

    Right now I also cannot connect to the host via SSH though remote console sessions to the guests are working.