Kaseya Community

KNM v5 monitoring ESX 4.x

  • Hi all

    KNM 5 monitors VMWare esx 5.x servers natively. Create a blank device and after creation, the VMware monitors are applied.

    But doing the same to a VMWare esx 4.x server, no monitors are applied to the device.

    Is there another way to monitor the VMWare 4.x servers in KNM. If so, can someone post the information.

    Eamonn

  • Have you tried setting up the device with root credentials and just running an "Inspect Now"?

  • Hi

    Yes just tried that. Still no preconfigured monitors for VM4.x

  • The VMware monitor have been developed and tested on ESX 4.1 (but unfortunately we have presently no access to any machine with that version), and ESXi 5.0. Most likely it also works with ESXi 5.1. What exact version are you using?



    Our QA tester says he have also tested it on ESXi 4.1 and ESXi 5.1 without seeing any problems.
    The VMware monitor uses a subset of the VSphere Web Services API to communicate with the host. The protocol is HTTPS and the port is normally 443. The credentials for the VMware login (like in VMware vSphere Client) is set in the tree (on the device or above) and the port number on the device.
    For more information, see: http://help.kaseya.com/WebHelp/EN/KNM/5000000/index.asp#10413.htm
    See also:
    * http://community.kaseya.com/kb/w/wiki/knm-vmware-performance-monitor-no-result-returned.aspx
    * http://community.kaseya.com/kb/w/wiki/1035.aspx

    [edited by: Stefan Rådström at 2:17 AM (GMT -7) on Oct 8, 2013]
  • ESXi 4.1 template.xml

    Import the attached ESXi 4.1 template.  Just add VMWare Performance monitor (datastore.totalReadLatency.average -AND- datastore.totalWriteLatency.average) for your instances (divisor:1, data type:latency/ms) and that will give you a good overview.

  • Hi all,

    Thank you for all the replies. BTW KNM ver 9827. Going to update, again, next weekend.

    We have found something that could be a bug.

    On an ESX 4.0 box. If we create an ESX 4.0 device, no monitors are preconfigured. But if we change the operating system setting on the device to ESXi 4.1, then the preconfigured monitors are available.

    Changing the os setting on the device back to ESX 4.0, still keeps the monitors working.

    There must be something on esx 4.0 os setting that is stopping the preconfigured monitors.

    Eamonn

  • Hi,

    Then it works as designed. The internal template is only applied to ESXi hosts, versions 4.1, 5.0 and 5.1. It's not applied if you set the OS to ESX 4.0 or 4.1. This is because we never tested on ESXi 4.0, we started supporting from version 4.1 and onwards. It's great that it works under 4.0 though, but as I said, we have never tested/supported that platform. It could as well be that "under the hood" it's the same as 4.1 so that's why it works if you set it to one of the supported versions.

    Regards,