Kaseya Community

KNM v5 monitoring localhost

  • I just upgraded to v5 and I'm having trouble monitoring the server that hosts KNM.  It tells me "Queries to localhost cannot use an account. Set monitor to use No account.".  The problem started when I entered a domain account at the top level and I couldn't figure out a way to set the monitoring server to "No Account".  It won't let me have a blank user name.  I was able to work around it by removing the account from the top KNM folder and then set the monitoring account info on the lower folders.  However, this seems to defeat the purpose of the hierarchy.  

    Is there a more elegant way of setting a single computer to "No Account"?

    Thanks,

    -John

  • Hi,

    Authentication for WMI is not allowed on localhost. We've solved this by entering the device address for the KNM monitoring device (local or or remote gateway machine) as "localhost" or "127.0.0.1". When you do that, authentication will not be used for that device. Thanks for bring this to our attention, the documentation needs to be more clear about this.

    Regards,



    [edited by: Tomas Andersson at 1:05 AM (GMT -7) on Mar 18, 2013] Edited to make the response more clear
  • Got it.  Thanks!

  • but...this didn't answer the question (I know, it's 8 months old...sorry).  I understand WHY this is an issue, the question is, how do I keep my hierarchy with my accounts and 'block' the local knm gateway from using that account (therefore causing the error)?  Surely the answer isn't that I have to forego the inheritance for a single server?