Kaseya Community

KLC Issue where screen is shifted up and so mouse clicks are not registered properly.

This question is answered

Hi Everyone,

Experiencing a strange issue when using Live Connect that I hope you can help with.

Since upgrading to the latest version of Live Connect -  9.4.6409.1304 a number of our users when they connect to machines via Live Connect the machine will be both missing the blue bar with Ctrl+Alt+Del on the top (you can see a few pixels of the bottom of it)  It's like the whole live connect screen has been shifted up by 50 or so pixels. So when they click on the screen where the host mouse actually registers that click as being is off by a half an inch. 

This means they have been accidentally clicking links because where they click on Live Connect screen doesn't match where the click happens on the machine they've connected to. As it is it's pretty unusable.

I can't seem to reproduce it on my own machine and i'm on the same Live Connect version as them. They have completely uninstalled Live Connect and installed it again.  Rebooted machines and host machines. This happens on any machine they connect to. They are using Windows 10 and Chrome as a browser.

Any troubleshooting steps, ideas or help would be appreciated!

Thanks in advance.

Alan

Verified Answer
  • We had the issue resolved this morning by placing a file called 'KaseyaLiveConnect.ini' into c:\users\(username)\AppData\Roaming\Kaseya.  (you will probably need to create the Kaseya folder)

    Contents of ini file are;

    [Renderer]

    UseOpenGL=false

    Marty

All Replies
  • We are seeing the same thing although we also have not found a way to reproduce it. The mouse being a half inch off is annoying but also potentially dangerous if it has not been noticed.

    This appeared for us after installing patch 24 a couple of weeks ago.

  • Can you try the following and report back? From your machine, go to the directory:

    %APPDATA%\Kaseya\KaseyaLiveConnect.ini

    If the file doesn't already exist, create the file and edit it with the following:

    [Renderer]

    UseSWRenderer=true

    Then reload Live Connect and see if the mouse cursor placement is accurate this time.

  • Tried that fix here on an affected machine. No dice.

  • Did the Live Connect update coincide with a Windows update or video driver update? Is there anything specific on the machine that's different from yours? For example, is the machine running 4K resolution? Just wanted to confirm on that before we dig in further.



    Added suggestions.
    [edited by: jeffrey.odolski at 8:54 AM (GMT -7) on Aug 3, 2017]
  • No not for us. In fact on the machines with 4k resolution, the fault is not being seen, but nothing else has been changed other than updating KLC following a patch.

  • We've also noticed the same issue, Was just doing some remote work now, and it was quite frustrating.

    I've noticed it on our 1080p resolution screens only at this stage

  • Hi Jeffrey.

    Sorry for the delay.

    The machines in question are all Dell XPS 13 9360. My own is a HP.

    There were a number of patches installed in the last 2 weeks on 2 of our 3 affected machines. They were not specifically graphics related but rather Audio, Bluetooth, BIOS, etc. All 3 users first noticed the issue when we upgraded to 9.4.0.26.

    Patches Installed were:

    Patch Installation: Intel(R) Corporation - System - 3/31/2017 12:00:00 AM - 9.21.0.2277

    Patch Installation: Dell, Inc. - Firmware - 7/4/2017 12:00:00 AM - 1.3.7

    All machines are running Windows 10

    The machines run at 1080p and 4K resolutions and the issue occurs at both resolutions.

    I haven't tested with lower resolutions yet to see if that makes a difference but will do so and get back to you.

  • Setting UseSWRenderer=true makes KLC use over 25% CPU and almost 50% if RC is also open.

  • We had the issue resolved this morning by placing a file called 'KaseyaLiveConnect.ini' into c:\users\(username)\AppData\Roaming\Kaseya.  (you will probably need to create the Kaseya folder)

    Contents of ini file are;

    [Renderer]

    UseOpenGL=false

    Marty

  • Thanks Marty. This worked for us here also. Appreciate your help on that one!

  • Thanks that also fixed the CPU usage problem!

  • Others have reported their issue resolved just by disconnecting and reconnecting their monitor cable which forces it to reinitialize. See if this works before adding launch parameters.

  • Isn't that the same fix?

    We had the issue resolved this morning by placing a file called 'KaseyaLiveConnect.ini' into c:\users\(username)\AppData\Roaming\Kaseya.  (you will probably need to create the Kaseya folder)

    Contents of ini file are;

    [Renderer]

    UseOpenGL=false