Kaseya Community

LiveConnect not working at all after 9.2 -> 9.3 upgrade

This question is not answered

Just upgraded from 9.2.0.18 to 9.3.0.8 over the weekend.  After getting through a number of other issues, it looks like we're down to one major functional problem left:  LiveConnect isn't working.


On any system (PC, Mac), and from any browser (tried Chrome, Firefox and IE11), when I hover over a status light and select "LiveConnect" from the pop-up, I get a LiveConnect window that opens, but get the error "Server error occurred but could not be parsed".


My LiveConnect log shows the following:

[I 2016-06-13T09-19-14.873Z Pacific Daylight Time 27232 0xdf5d43a080] [lc.default] ---------------------------
[I 2016-06-13T09-19-14.873Z Pacific Daylight Time 27232 0xdf5d43a080] [lc.default] Kaseya Live Connect Started. Version: "9.3.5998.34549"
[I 2016-06-13T09-19-14.873Z Pacific Daylight Time 27232 0xdf5d43a080] [lc.default] ---------------------------
[I 2016-06-13T09-19-15.152Z Pacific Daylight Time 27232 0xdf5d43a080] [lc.default] Admin Endpoint connected successfully
[W 2016-06-13T09-19-16.458Z Pacific Daylight Time 27232 0xdf5d43a080] [lc.js] "/deep/ combinator is deprecated. See https://www.chromestatus.com/features/6750456638341120 for more details."
[C 2016-06-13T09-19-16.466Z Pacific Daylight Time 27232 0xdf5d43a080] [lc.js] "Server Exception"
[C 2016-06-13T09-19-16.467Z Pacific Daylight Time 27232 0xdf5d43a080] [lc.js] "Unable to retrieve Admin Jwt: Error: The request failed with status code: 500"
[C 2016-06-13T09-19-16.947Z Pacific Daylight Time 27232 0xdf5d43a080] [lc.js] "Server Exception"
[C 2016-06-13T09-19-16.948Z Pacific Daylight Time 27232 0xdf5d43a080] [lc.js] "Unable to retrieve func list info: Error: The request failed with status code: 500"
[C 2016-06-13T09-19-16.952Z Pacific Daylight Time 27232 0xdf5d43a080] [lc.js] "Server Exception"
[C 2016-06-13T09-19-16.952Z Pacific Daylight Time 27232 0xdf5d43a080] [lc.js] "Unable to retrieve func list info: Error: The request failed with status code: 500"

Any suggestions?  I've already filed a ticket (yesterday) but have not had any response from Kaseya support other than the auto-responder.

All Replies
  • Contact support. I ran into the same thing after upgrading this weekend. It sounds like a known bug and they have to fix some passwords.

  • Did you get this sorted ? im having the exact same issue and support are taking a very long time to resolve

  • No, support never got this fixed for us.  Just going around in circles every couple builds asking for logs and I finally got tired of re-sending them.  At 9.3.0.17 now and it's still broken.  Looks like there's a 9.3.0.19 out now, may try that over the weekend but I'm not really hoping for much.  We've just got the VSA set to use the old LiveConnect which was adequate for our needs.

  • Yea same here not getting anywhere, is it easy to revert to the old version then ? Im taking over management of our VSA at my site so i am still learning the ropes currently. I noticed the new patch and was actually looking to upgrade etc but if i know i can revert back to old live connect ill be a happy man !

  •  - I have escalated your ticket.

     - As you do not have any open tickets at this time, I was unable to provide any updates to support on your current status. However, your issue was linked to a problem ticket which was corrected in 9.3.0.17. If you still have this issue, I encourage you to create a follow up ticket

  • leeshaw: you don't need to revert the VSA to the old version.  There's a setting inside Kaseya VSA that just tells it to launch the classic LiveConnect versus the new LiveConnect.  Go into System...Default Settings.  Find the setting (on mine it's the last in the list) "Use new Live Connect when clicking the Live Connect button in Quickview", select it, and click the [Edit] button, and change the Yes to No.  Save, close, and re-launch, and now any time you select LiveConnect it will launch the 9.2 working LiveConnect versus the 9.3.

    Nicolas, my ticket # is 139756, and yes, at 9.3.0.17 the issue remains unresolved and functions identically to prior versions.

  •  

    Your ticket has been closed at this point, I created a follow-up instance for you from the original ticket so it can be reviewed again, ticket #:156772

  • Hi i would like to ask if there is already a resolution regarding on this issue?

    Thanks!

    Ryan

  • Hey - the new Live Connect has been improved on a lot of times. We're on 9.4 and still have the old Live Connect active. I must admit the new Live Connect sometimes works better than the old version. The beauty of the new Live Connect is you can launch it as a separate application, next to your VSA. This way you can have the best of both worlds and can use the version that accomplishes what you wish to do....