Kaseya Community

Keyboard language in RDP connection

This question is not answered

Hi,

Every time I connect to a computer thru KLC with RDP the keyboard language defaults to English. Even if I log in to the server with VLC, and removes all traces of English keyboard it comes back at the next RDP session.

Why is this and how can i prevent it?

 

Regards,

Nicklas

All Replies
  • I have the same problem and have done extensive testing to figure it out.

    The trick I found is to enable the language bar and add in English UK as a keyboard layout, this lets you switch between the two mode as needed. Refer to the ms KB article that describes how to add the keyoard support.microsoft.com/.../258824

    Once it is set up, you can then proceed to tell the program which layout to interperet the incoming scan-codes as.  The bugger all is that it is a per-application setting and so you will constantly have to switch the language bar back and forth.

    I haven't used this work-around enough to know for certain, but I suspect you can just remove the layout and that will leave the computer configured correctly for hte next person to use it.

    KVNC, MSTSC, and the physical keyboard do not experiance these problems.  In fact, KVNC doesn't care what your language setting is because it doesn't interface with the keyboard as scan-codes.

    The fun part is that the login screen has a separate layout setting, so if that buggers up, you are screwed.

     

     

    I have a support ticket in the works: c086966, so hopefully they will diagnose the issue soon.



    [edited by: Nicholas Perry at 3:24 PM (GMT -8) on 1-12-2012] adding in note about support ticket.