Kaseya Community

Restart computer when windows "freeze".

This question is not answered

Hello everyone.

I got a big problem when it comes to restart computers when they "freeze". I tried typing in the Live connect Command shell; "Shutdown -r"
It says "Command now allowed". So that didn't work.

I tried with Live connect -> Task manager -> "Reboot" and then click on 'reboot'. And that didn't work. 

I tried with a script too. Even with the script that already existed. 

 

But still, Windows does still work. I can remotely control the computer and move the mouse around. It's just stuck on "Applying profile settings...". So what can I do to acctually restart this computer? And why isn't the command "shutdown -r" not allowed to be used? 

All Replies
  • Kaseya Support (or someone) - Is this question going to get answered?  If the Live Connect is responsive them it stands to reason that it should be able to initiate a sure-fire reset of some kind.

    R

  • I'm guessing that no one knows..

  • We have seen these issues and have leveraged a few different things to address this:

    1) You can execute the shutdown /m <machinename> /r from a remote machine which has worked sometimes when we cannot achieve a reboot through Kaseya.

    2) Tasklist and taskkill can give you access if you cannot get kaseya to kill tasks to a point that the system will reboot.  

    Obviously both require you to have access to another machine on the same network.

    3)  While not recommended, nor guaranteed to give you an unclean reboot instead of a BSOD, many times killing winlogon.exe through the task manager will force an unclean reboot and get the system back up and running.  Depending on the state of the machine you can leverage the klc task manager or use pskill from a remote machine if you have lost function of klc.

    None are ideal solutions, but they are some workarounds, but please test first and ensure you understand that in some cases you may bluescreen the system rather than reboot.

  • Hello Bryan,

    I will try all the things you wrote. But is there a reason that the "shutdown"- command doesnt work from KLC?