Kaseya Community

Internet Explorer 9 is now supported

  • All,

    I am pleased to announce that Live Connect now officially supports IE 9 browser. To use IE 9, update to the latest Hotfix version.

    Thanks,

    Patrick

  • IT Center on saas1.kaseya.net, Windows 7 x64 with SP1 (completely updated including yesterday's updates), Internet Explorer 9 (v9.0.8112.16421).

    Live Connect does not work, fails with "Unsupported browser detected, please upgrade to IE 7 or higher."

    It doesn't work in Opera (v11.10) either, so I had to download and install Chrome just to get access.

    Kind regards,

    Ole Andreas Ringdal

    Bergen, Norway

  • The hotfix will be rolled out to our SaaS environment during the normal update window on Thursday evening.

    Opera is not a supported browser.

    Patrick

  • Hi Patrick,

    Can you let me know the list of browsers officially supported by Kaseya 6.1 and/or 6.0 versions? Thanks in advance!

  • I have a lot of issues using IE9.  Especially opening two remote sessions, switching between those tabs, usually causes IE to crash.

    We are on ITCenter (saas2).

  • Latest KLC Performance hotfix seems to have Broken IE support for me.

  • Hi Peter,

    Please open a support ticket and work with them to resolve this issue. We tested this hotfix extensively on IE9, but real-world trumps a lab so we may have missed something.

    Patrick