Kaseya Community

"Connect AntiMalware Install" broken

  • We're moving from an old 6.5 server to a new R9.1 server.

    One of the items on our "moving agent' tasklist is to grab the KAM license from the old server.

    When I select machines in our first test group and click Install > Connect AntiMalware Install, the task fails.

    I opened a support ticket and the response was that this feature was to be used just to confirm that KAM is installed.

    "This option in Anti-Malware functions as a way to verify that Malware-bytes is installed without running a repair."

    Their fix is to uninstall KAM while the agent is on the old server, move the agent, install KAM from the new server.  That's time-consuming for us and inconvenient for the client.  It also goes against the help file:

    • Connect Kaseya AntiMalware - Reestablishes a connection to a machine that was previously managed by AntiMalware but had the Kaseya agent removed, then re-installed. This includes reestablishing a connection to machines that were managed by a different VSA. 

    Can anyone confirm what "Connect AntiMalware Install" is really for?  And if it is for grabbing licenses (without having to reinstall), how to troubleshoot the failures?

  • i've been through a couple multi-thousand agent migrations. the connect is virtually useless. fortunately KAM doesn't require a reboot so I would typically run a connect to get Kaseya to know the agent has KAM, then a repair which would normally work. if not, I would run install.

    if all else failed, reboot machine, delete agent from server without uninstalling, let it check back in and start the above process again.