Kaseya Community

KAM Install issues

This question is not answered

In the past few days we've had a slew of failed installs, and when you click on the "view log" for the installation it ends up with "File not found".

The status for some stays at "script scheduled" even when I do "Cancel pending action" from Actions.

Has anyone else seen this before I open a ticket?

All Replies
  • Ken,

    We've seen a few issues like this, but unfortunately there does not seem to be a prevailing pattern to them.  

    For the view log link, can you check if the log is created on one of the endpoints?  It is initially written to <kworking>\kam\logs\install.txt.  If your KWorking path (as specified in Agent -> Working Directory) has a space in the path, it will cause the log creation to fail, as well as the log parsing, that tells the KAM module the status on the endpoint.

    Check your KWorking, and if you have a space in the path, the recommended steps to update are:

    Update the kworking folder

    Copy the contents of the old kworking directory to the new directory specified

    Run the update agent process with the "Force update even if agent is at version" option selected.

    Additional information on Agent Working / Temp directory is available at community.kaseya.com/.../what-are-the-best-practices-for-configuring-a-k2-v6-based-agent-working-temp-directory.aspx

    If your KWorking does not have a space in the path, open a ticket, and include the install.txt and machine name of the endpoint being investigated, and we will diagnose further.



    Kaseya Support

  • Travis,

    I have had similar issues with KAM failing to install, and a "File Not Found" when trying to view the log.

    I followed your instructions above, and I looked in KWorking. There is no kam folder or any path similar to \kam\logs\install.txt. And there are no spaces in our KWorking path.

    What's worse for me is that I have been able to install KAM on every endpoint at this particular client except this one machine. And it fails despite everything I have tried. The only clue I am given is in the Summary pane. Under messages, it says: "Install: Script Summary: Failed THEN in step 4".

    Any help on that one?

    Much thanks,


  • We have had a similar issue on one machine, which turned out to be my own pc.

    Turned out Malware bytes was already installed on this machine. After running an uninstall of Malware bytes installation went without problems

  • Unfortunately for me, uninstalling Malwarebytes is not the answer in my case. I have rolled KAM out to maybe 100 machines now. Most of them had the shareware version of Malwarebytes on them. My first step is always to run the uninstall script from the Anti-Malware tab. There are always a few machines that refuse to let go of the shareware version, so I have to get on them, uninstall, reboot, then verify from the Anti-Malware tab. THEN the install will be successful.

    What I mentioned in my earlier post is a totally different situation. On this particular computer, I have run the uninstall script, manually uninstalled Malwarebytes, scanned the registry for any mention of Malwarebytes and deleted those keys, reinstalled the shareware version to let the script uninstall it, and disabled all Antivirus and other Anti Malware software to make sure it is not being blocked by any of them. All of this has failed. It just consistently says, ""Install: Script Summary: Failed THEN in step 4". Since I can't see the script, I have no idea what is going on.

    I even opened a support ticket with Kaseya, and the tech never really figured it out. It just so happened that the machine in question was being decommissioned, so we let it go. But now I have another machine that is doing the same thing. The last one was XP, this one is Windows 7 and is pretty new. So, this is still an issue for me.

  • Watsonatripple,

    Can you tell me the ticket number?  I'd like to take another look at it.  Please also create a new ticket for the new machine that is failing, and let me know that ticket number as well.  



  • Email MBAM support and get their MBAM Clean tool.

  • I have been fighting an install for a couple days now.  The free downloadable version from MBAM installs and runs just fine.  Then I uninstall it so I can install the Kaseya version and the install fails.  Initially there was a write error to the "C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Malwarebytes' Anti-Malware" folder.  I checked permissions and did not find anything out of the ordinary.  Now I have a Pending Uninstall that is stuck and cannot be cleared using normal means.

    I downloaded the MBAM clean tool from MBAM and it seems to strip everything except the KAM folder in the working directory.

    The last log file sure makes it look like in installed correctly but it reports a failed install in Kaseya.

    Any ideas for troubleshooting or backdoor for killing the Pending Actions?


  • I am running to the same exact thing. Did anyone ever get an answer to this?

  • This was a while ago, but the answer for me revolved around the "Microsoft 2005 C++ Redistributable package". Either uninstalling that using a Microsoft uninstall utility or installing it using a Microsoft install package was what fixed it (forgive me, I'm going on memory here).

    Basically, the MBAM install script from the KServer wasn't correctly installing the C++ package I mentioned. Making sure it wasn't installed on the client machine and then running a stand alone installer followed by pushing out MBAM from the Kserver fixed the problem.

    Hopefully this will point you in the right direction.  

  • I'm also having this same issue - KAM not installing - just hanging with Pending Install.   I tried the suggestions watsonatripple indicated, but haven't had any success.  Has anyone been able to figure this one out?

  • Ron,

    Please check the agent procedure log and share the results during the time of the KAM installation.