Kaseya Community

Cant' get Kaspersky anti-virus 'Installed' on an updated Windows 8.1

  • I have Kaspersky installed under Kaseya agent on a Windows 8.0 machine.

    Then I updated that machine to 8.1 and now I can't have Kaspersky to show "Installed" even do it seams to be installed and working fine on the machine.

    I had to disable it in order to install Windows Update to 8.1

    then when I try to re-enable, did not work. so I removed (uninstall) and try to re-install 

    didn't worked

    I edit REGISTRY removing any entry I could found there that was referring to Kaspersky.

    Then I try the re-install again.

    Looking directly from the machine, it is installed, but looking from the Kaseya Anti-Virus monitor, is show "Repair Failed" (which was my last action) with a big red exclamation mark on it.

    The column "AV Installed ON" shows blank and the "WSC Reported Product Name " shows "Kaspersky Endpoint Security 10 for Windows"

    I can't run any scan from the Kaseys, but if I remote connect to the machine, I can run updates and scans.

    Any ideas?

  • I've had a run of bad luck with KAV for one reason or another I have notice that one out of every five kav deployments fail and attempting to resolve issues seems to make problems worse half the time.

    Sometimes following these steps help  helpdesk.kaseya.com/.../104129073-7-Steps-To-Troubleshoot-KAV-Installation-Failures mostly the removal tool, but if not - I'm afraid a clean install will be your only option until KAV becomes better supported under Kaseya.  

    From what I've been told by CS, Kaseya also supports  KES (AVG). &  webroot (needs be be purchased directly through them) might be less of a mental strain; to swap AV's rather than fighting a loss battle with KAV.

  • Hi ehm01 and timypcr,

    It seems the new KAV module has some rough edges, but these should be not to hard to resolve for our Kaseya friends. We do have an active ticket for these issues and have asked for some extra attention to get a workaround or fix out there.

    Will update this if I have some extra information, should be today.

    OudjesEric.

  • thanks I'll look forward to it.

  • It seems this issue hasn't been reported in a ticket yet, our ticket was the first.

    The issue has been confirmed by support and they're discussing this in an hour or so. You can create a ticket to get support involved and they should link these similar issues and resolve this in one go. Waiting to see what conclusion they reach, should know more tomorrow.

  • i have a ticket open for 2 weeks now. with errors with KAV 118908.

    in this 2 weeks kaseya managed to solve the issue twise. though kav did work for a couple of hours

    then need support again to get things going.

    one agent had a failed install of KAV. logged on manualy. still kaseya tells me there is a failed install on the machine. and when you want ot do something you need to reboot the machine

    the machine rebooted repeatly on the clinet, or by kaseya script. . the button reboot in kav is not working. the machine still needs rebooting tells KAV

    got a agent procedure from support to run on our sql server every 30 minutes to get things going. but this also does nothing after 2 procedures run.

    ran all audits on this agent this also does not help.

    hopefully support can find a solution soon.



    typo
    [edited by: FSmidt at 2:00 PM (GMT -8) on Jan 28, 2016]
  • Sounds like you need to run either a repair, connect, uninstall, install or use the KAV removal tool from kaspersky directly. For particularly mucked machines use all of the above.

    If it is a kserver / KAV module issue then you're SOL until support helps you.

    You could try, 're-apply schema', Repair, reinstall, ect..

    Once we had an issue where the KAV/KAM alarms were slowing the KAV module to the point where once a KAV related procedure was scheduled, it would take days to process.



    typo - DUH!
    [edited by: jorigas at 3:49 PM (GMT -8) on Jan 28, 2016]
  • Waiting on feedback for our call, haven't gotten it yesterday, will take a few hours more.

    We can confirm that doing a reinstall for KAV or any kind of remove and reinstall won't work.
    From colleagues I've heard it only worked once on a Win10 machine.
    It looks like some sort of timeout or left behind information in the ksubscibers database.

    The number of these PC's and even servers with this issue is growing daily.
    There are no known SQL or queue based issues I'm aware of, so the new KAV module most likely is responible.

  • had some support on our case bij Kaseya (Olu)

    He provided a agent procedure to set on our sql server every 30 minutes to do a cleanupkavtables on our ksubscribers database. this seens to help.

    it is a temp fix till till some fixes will be available (next update?)

    they seems aware of problems and busy sorting things out.