Kaseya Community

agent procedure not approved - KAV install

  • Is any one got the workaround or resolution for this issue.. I have to install AV on two servers but we get the agent procedure approval error..

    Please let us know if there is an workaround to fix this.. Kaseya updated with the latest patch level 7.0.0.18

  • I am also seeing this issue. If someone has a known working solution that would be wonderful. I am opening a ticket now.

  • The latest patch from Kaseya should have already addressed this issue.

  • , Which patch fixed this issue? Up until this morning I was on the most recent patch (7.0.0.18). Sometime after I looked for a new patch yesterday, they released the 7.0.0.19 patch.

    I see the bug fix for KAV in the .19 release stating: •Fixed an Antivirus 'Post Install' script failure. (IP-338/SECBAK-1238)

    I don't know if this is the same bug as the one I am seeing, but i would assume not because mine doesn't start the install. and gives this error: FAILED to load KAV: Get Install Log (ID = XXXXXXXX). Error: This agent procedure has not been approved yet.

  • It's not fixed. Just tried it. I think they fixed the part where a procedure called "unnamed" was failing. I can't believe this hasn't been done yet. I've got installs waiting from 2 months ago.

  • I just ran the 7.0.0.19 Patch update that the tech told me would fix the issue. Stayed late, ran the patch update, made sure the system came back up, updated the agents, uninstalled The AV that was on the system after my initial attempt removed what they had. I rebooted to give the system a nice clean start. Ran the AV installer and I am still getting the same error:

    FAILED to load KAV: Get Install Log (ID = XXXXXXXX). Error: This agent procedure has not been approved yet.

    Hopefully this gets fixed or maybe they can provide me with a workaround because I need to setup my clients as they are running out of their licenses on their existing AV.



    typo
    [edited by: Matt S. at 3:53 PM (GMT -7) on Aug 21, 2014]
  • Same thing over here

    Now mind you, this is going on my 2nd year with KAV issues. My KAV issues started from the 6.0 "test pilot" program so for 2 years i have been hearing the same god damn excuse. I am literally about to go to my attorney to sue this company. I am sick of this ***

    Why haven't we ditched KAV all together. Because we always get the "oh wait until this release and it will be fixed" yeah BULLSHIT

  • The patch level when I noticed this issue fixed was .18 - Have not upgraded to .19 yet.

  • Kaseya just released a new patch today 7.0.0.20. Support told me that this patch would fix this issue and resolve the problems that this thread has been talking about. I am going to update and let you know how it goes.

    **Fingers Crossed**

  • Well it looks like I am no longer getting the Agent Procedure not approved error anymore. But now I am getting a different fail message about not being able to get the install logs. Time to go home and let Future-Me deal with this.

  • It looks like I was able to successfully install the AV to the endpoint after further troubleshooting.

    I would like to thank for his post in this thread that got me the troubleshooting steps i needed to figure out the new issue: community.kaseya.com/.../20096.aspx

    I don't know why these troubleshooting steps are not in the Kaseya KB but they sure would have helped me earlier today: virtualadministrator.com/.../7-steps-to-troubleshoot-kaseyakaspersky-anti-virus-kav-installation-problems

    So in conclusion, grab the 7.0.0.20 Patch to get rid of the Error: This agent procedure has not been approved yet.

  • Yes this is a known issue. It's under invetigation by the Dev team. I have ticket #44579 (and #40105) open for a month now. The issue is with multiple machines at multiple ORG's. It can be solved by removing KAV with the Kaspersky Removal Tool - Reboot and a reïnstall.

    The last answer from Kaseya:

    There is currently no patch for this but they are investigating it.

    It will likely be resolved in v8 once the issue has been found.

  • This problem has returned after the latest patch. I don't like the idea of waiting for our turn for R8 since we haven't even received any email about it yet.

  • Where are you seeing the agent procedure not approved error?  one of my techs has had major issues installing/fixing KAV, and I'd like to see if that is the cause.

  • This will show in the agent procedure logs for the endpoint attempting the install