Kaseya Community

After KAV installation Cisco VPN connects but cannot reach vpn network

  • After instaling Kaseya Anti Virus 10.2.1.23 i can connect to all of my customers but when i try to reach the vpn network just bij pinging the DNS or DC i get no reply.

    Neither i can connect by RDP.

    When uninstalling KAV i can connect again through  my Cisco VPN client (5.0.07.0440)

    I am running Windowss 8.1 X64

    Some customers need the Cisco VPN client to connect to their workspace if they work from home.

    I already excluded all of my cisco executables as a trusted application but still no luck.

    Can anyone help me try to solve this problem ?

  • I am also experiencing the same issue here in our platform. After installing KAV on all our servers, we are not able to connect using VPN from my home. The VPN connection establishes but we are not able to connect through RDP.

    In office, we are able to access the servers through RDP. It is not working only when we connect through VPN.

    We are using the same Cisco VPN Client version (5.0.07.0440). I have tested this from Windows 8 Machines.

    Rob, Have you raised a support ticket for this ?

  • Yes, i raised a ticket to support for this, still waiting for an answer

  • Thanks for sharing the info. I'll hold off on 6.5 and KAV 10 then.  Can you post an update when this issue has been resolved?

  • Hi,

    There is a known issue and you can find a workaround here - helpdesk.kaseya.com/.../33803618-VPN-connection-is-established-but-cannot-connect-to-the-remote-network

    Can you try this out and let us know if it helps?

    Kind regards,

    Chris, Kaseya Support

    ---------------

    Still no definitive answer, just a workaround wich does not work

    And ofcourse a default answer, Helloooooo, i am using a cisco vpn client not the live connect VPN Tongue Tied



    added a line
    [edited by: Rob de Vries at 6:18 AM (GMT -8) on Feb 25, 2014]
  • Hi Rob,

    I have also raised ticket and the same answer for me as well. I have responded back stating that it is not "live connect"..

  • We had a similar issue with PPTP VPN connections being established but seemingly not routing correctly - the fix for us was to apply this Kaspersky 'private fix' to the RRAS server - support.kaspersky.com/10907

    Note that once this was installed the agent started reporting 'out of compliance' in the KAV console and this probably 'not supported' as a solution by Kaseya (yet).

  • Dear Rob,

    Are you able to fix this issue. I am still waiting for the solution from Kaseya and i keep sending the logs to kaseya  which are requested by Kaspersky but there is no solution yet.

    Let me know if you have found any workaround

    Thanks.

  • Anyone find a solution to this.  We are having it as well?

  • This only seems to be a problem with Windows 8.x.

    I got patch pf401 from Kaseya by opening a ticket #21895

    helpdesk.kaseya.com/.../iREklpmSfmQn6lsGhyiXq1Mv2

    From my ticket

    To install pf401 please run it from elevated command prompt with "/when now" parameter and restart computer afterwards. Installation takes about 1-2 minutes, during this time KES icon will disappear and appear again in the taskbar. If patch is installed successfully you will see it listed on the KES About screen.

    Please try it and inform us about results.

    Regards,

    Jonathan Sanchez

    Support Specialist

  • Thanks for the reply. We've found it is with Windows 8 and 8.1 using KAV.  Funny the main reason we went to Kaseya 7 was for KAV and KRC now we have to stay with KES if they cannot fix it.  We have a ticket open as well (31804).  I really hope there is a better solution we can't login to every machine and do this.  

  • We also ran into this issue and one of our engineers found this workaround that works for us:

    ---------------------------------------------------------------------------------------------------------------------------

    So I found a possible fix for people using Kaspersky Antivirus. My company is thinking about moving to Windows 8 machines and I've been tasked to putting together the migration path. We have hit a snag with Windows 8 and Cisco VPN client (5.0.07.0440 and 5.0.07.0410) and Kaspersky Endpoint 10 (10.1.0.867). The VPN client would connect but I am not able to hit any of our servers on the VPN network. I tried many of the prescribed solutions from adding exclusions to the Kaspersky firewall etc. The only way I was able to get the VPN to finally work correctly was to not have the Kaspersky NDIS filter 6.0 from starting up. This requires a registry change. Below are the steps:

    1. In Kaspersky, you must first disable Self-Defense

    2. Go to your registry by typing regedit in the run menu

    3. Navigate to \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\klwfp (note: for older Kaspersky versions it might be kltdi instead of klwfp)

    4. There will be a key called "Start" and should have a default of "1". Change that to "4"

    5. Enable Self-Defense again and restart

    6. Once restarted when you connect via the VPN, you should be working again.

    ----------------------------------------------------------------------------------------------------------------------------

    Not something you would wish to do on a lot of machines, but in a pinch this should get you up and running.

    Eric (Aspect ICT).

  • Thanks!  We've tried that as well.  Even have an Agent Procedure to make the change on machines.  It does work however after a while it will show as not installed or failed in Kaseya after doing it.  Breaks the connection somehow.

  • OK, I haven't heard that yet from our engineers.

    Good to know we might run into this.

  • The Patch PHlight mentioned does work but we hate needing to deploy that to every machine that uses it.  Stays associated with Kaseya as well.  We still have not even had a response from Kaseya Support on our ticket.