Kaseya Community

Unable to upgrade or install KAV 10

  • i am seeing the following error in procedure LOG

    FAILED in processing THEN step 28, Execute File, with error File or Directory Not Found, "C:\Program Files (x86)Management\xxx123123\Scripts\KAV\BinModules\kav2srv.exe" /r



    changed path
    [edited by: Baltasar32 at 8:04 AM (GMT -8) on Feb 12, 2014]
  • I too am having the exact same error on multiple machines whether it be a new install or an upgrade. All Win 7 x64 machines.  I now have machines with no AV as I can't go back to v6.  Any updates on this issue kaseya??!!!

  • I've got the same error! What's up Kaseya?

  • We are looking into this issue at the moment.

  • Are you guys able to deploy Kaspersky 10 after the Kaseya 6.5 update.  We are wanting to deploy a newer AV Engine but it sounds like there are a lot of problems at the moment.  Any update?

  • I'm getting the same error now, I think, since the 6.5 upgrade.  I have numerous machines now with no AV since it will not install.  This is the reply I got yesterday from support: "I have gone ahead and confirmed this issue on our end and have notified our developers of this issue. Once I have an update, I will go ahead and update this ticket accordingly. Thank you for your patience".  If this has been going on for over a month then I certaqinly hope we've extremely close to a resolution.

    Does anyone know if there is a way to manually download the KAV installation file and install it locally and then just connect it to Kaseya afterwards?

  • I am stuck in the same boat.  There should be a folder called KAV in your working directory.  There is a 180~MB installation file for KAV.  Run it and it should install.  However, I cannot get KAV10 to link to the console.  Repair installs fail and full installs also fail.

    Just to note too, if your KAV10 install is missing a key/license file, perform a full install and the key should be there within about 1-5 minutes.  

  • I would really appreciate some news or a fix for this issue.  6.5 was supposed to be the trust installation.  I have a ticket that is sitting unassigned and it's been in that status since I put it in 4 days ago.

    We have down-stream clients that are threatening to go to a different provider due to Kaseya/KAV issues.  It's not good when installs fail and I have to explain that we are waiting on Kaseya for a fix.  It makes me look incompetent and reflects very poorly on Kaseya.

  • Kaseya support fixed a database issue.  That seemed to clean up KAV.  I am able to install and machines are checking in to the KAV console properly.

  • Manual installations are not supported - If you install manually and the system detects it as 'installed' you will incur licensing issues in the future.

  • I still have KAV 10 failing on the vast majority of machines. I've had very limited success running KAV repair as suggested by support and slightly greater success uninstalling and reinstalling, but there is still a problem out there somewhere and support is very slow to respond if at all.

  • We were due to perform an upgrade to the VSA tomorrow due to the Desktop Heap Allocation issue in KAV (on VSA 6.3) - but having asked Kaseya for a list of 'known issues' of KAV to ensure that the things we were worried about had been resolved (and being refused said list) I have had no sensible choice but to cancel the upgrade project. Really, really unimpressive.

  • I would like to reiterate that Kaseya had to fix a DB issue on my end.  Once that was fixed, KAV10 has been working well.  I have about a 75% success rate on installations.   I noticed that I am having to manually point KAV10 at license files regularly.  However, this can be done through RDP, which is easily enabled through agent procedure.  We are also only pushing to Windows 7/8/8.1 machines.

    I noticed that on a few machines I could not successfully install.  Upon running a manual install, I received an error about installation data.  I looked at the error and it appears that this folder is causing issues: C:\Program Files (x86)\Kaspersky Lab. I am able to install once I delete the folder.

    I have not moved to servers yet, but KAV10 from my perspective is relatively stable.  I have had a few calls about performance after KAV10 upgrade, but those issues seem due to profile and lack of proper exceptions.  They also come from clients that like to complain about AV and seem to have limited understanding of how AV actually works.

  • I'm curious, what do the exclusions look like for you guys? Below is a screenshot of an example for us, and all of them have the Object Name field defined as "not-a-virus:RemoteAdmin:Win32:RAdmin.*"

    That doesn't seem right. Thoughts?

  • I believe that entry is made by Kaseya from the management perspective as a definition for the object name in the Kaspersky UI:

    As far as Kaspersky specifications on the object name:

    If you have excluded threat mask not-a-virus:RemoteAdmin* from scan during Kaspersky Anti-Virus installation, tasks Real-time file protection, Script monitoring and all on-demand-scan tasks already use this exclusion (except the task Scan Quarantine objects, because there is no need to exclude remote administration software from them).

    I also believe this allows kaseya functionality to be unaffected by exclusions set on the respected endpoints.