Kaseya Community

Upgrade to KAV v10 Breaks Mouse

  • Has anyone had issues after upgrading KAV to v10 where the mouse and/or USB devices won't work? If so, what is the best way to fix the issue?

    Thanks!

     

  • Hi,

    First ensure the installation has been completed successfully and completely.  There are times where Kaspersky installations do not complete successfully and certain system files are not appropriately replaced.

    --------------------------------------------------

    If you have confirmed the above try this:

    Download registry file:

    Turn on the computer and download our registry file: ftp2.kasperskyftp.com/.../USBRestore.zip

    Save this file to your Desktop.

    Right-click on the file USBRestore.zip and choose Extract, then Finish.

    A window with the registry file will appear. Please double-click on it.

    Press Yes to allow the file to be added when prompted.

    Restart your computer and USB will be working again.

    If the above method does not work, I recommend executing the KAV removal tool:

    media.kaspersky.com/.../kavremover.exe

    and re-installing Kaspersky.  

    --------------------------------------------------

    If the issue persists - Please create a Kaseya support ticket.

  • I just upgraded to 6.5 and started doing AV roll-outs.  I've had this happen twice in 12 installs and was instructed to run kavremover in safe mode.

  • This is an issue with the version of Kasersky and XP it corrupts the mouse drivers and keyboard drivers.

    The solution we have found so far ( work around) is remove kaspersky, system restore make sure kaspersky is gone and find the drivers again.

    horrible method.

  • I had this happen to two XP machine and 1 Windows 7 machine.  I have a case open with support to make this rollout less painful.  I'm also experiencing a lot of install failures that leave the machines in limbo.

    Cisco VPN Client was broken with the upgrade as well.  Kaspersky gave me a patch that fixed it but I'm waiting for Kaseya to make this patch part of the typical install process.

  • I had this happen to the same Windows 7 machine two nights in a row.  The first time we tried KavRemover and the USBRestore.reg fix.  Finally wound up laying down an Avamar image.  

    The second night we tried the upgrade the USB mouse broke again.  Based on information found here we discovered that UpperFilters in HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E96F-E325-11CE-BFC1-08002BE10318} contained both klmouflt and mouclass filters.  Once we deleted the klmouflt entry and rebooted we had control over the mouse again.

  • We've seen this on about 10 machines out of 60 so far.

  • Bill is right above. All you need to do is check the UpperFilters under

    For USB Mouse - HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E96F-E325-11CE-BFC1-08002BE10318} edit the key UpperFilter and remove anything except mouclass.

    For USB Keyboard HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E96B-E325-11CE-BFC1-08002BE10318} edit the key UpperFilter and remove anything except kbdclass

    For Smart Card Reader HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{50DD5230-BA8A-11D1-BF5D-0000F805F530} edit the key UpperFilter and remove anything except scfilter.

    This is applicable for Windows 7, not sure what would be the registry key for Windows XP.

    Sudeep

  • I have done the above and rebooted It does not work for my mouse.  The only way to get it to work is to remove Kaspersky!  Are there any other solutions.

  • See this support.kaspersky.com/.../10663 "Edit the Registry"

    Usually the above works.  If not, try

    Delete the value of klmouflt (only value, leave the rest) from key UpperFilters of the registry branch HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSetXXX\Control\Class\{4D36E96F-E325-11CE-BFC1-08002BE10318}

    Delete the value of klkbdflt (only value, leave the rest) from key UpperFilters of the registry branch HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSetXXX\Control\Class\{4D36E96B-E325-11CE-BFC1-08002BE10318}

    Delete the value of klfltdev ((only value, leave the rest) from key UpperFilters of the registry branch HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSetXXX\Control\Class, if such values are found.

    Delete the klmouflt key from HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSetXXX\Services\

    javascript:void(0);

    If it still does not work, delete klfltdev key from HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSetXXX\Services\

  • Had this issue on some machines, and Kaspersky's KB article on it was not 100% accurate on why it was happening.

    So the USB mouse stops working because the registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96F-E325-11CE-BFC1-08002BE10318}\UpperFilters contains a value of klmouflt.  Kaspersky no longer uses this, at least with KAV, so you should never see this value in this key.

    The problem we had was that an old version of Kaspersky (KAV 6 I believe) that did include the klmouflt.sys driver did not remove all traces of itself from the Windows Registry during uninstall.  Specifically you should look and see if you have this key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\klmouflt

    If that key is present you will need to either start Windows in Safe Mode or uninstall KAV so you can delete it.  Even though the filter is no longer part of the KAV package, avp.exe (the Kaspersky Windows Service instance) has code in it that still does all the work it used to so long as this key is present.  Once the key is removed, avp.exe will stop adding klmouflt to UpperFilters.

    Hope this saves someone else some grief.  Had an awful support experience working on this issue (third party components get complicated when you can't talk directly to the third party) but the fix is very, very simple.

  • I can just verify that our organization has encountered USB-mouse stopped working. Uninstalling and deleting HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\klmouflt has worked so far.

  • This is how i resolve the issue if removing the klmouflt entry doesn't work.

    Uninstall KAV from workstation using Kaseya web interface

    Restart workstation

    Log into machine remotely and run kavremoveal tool (download from Kaspersky) *NOTE* i don't run this in safe mode and haven't had any issues thus far (months)

    Select to remove "Kaspersky antivirus 2010"

    Restart workstation

    Redeploy KAV10 (let it auto reboot after installation)

    Check with end user if mouse is functional

    In 100% of my cases the above resolves the issue.