Kaseya Community

Discovery Failing Across Multiple Servers

  • I am seeing a recurring event happen with Discovery.  Things will be going along great then all of a sudden I will get a handful of servers failing DNS Scan and Quick Scan. Checking the system I see 7-10 task manager entries flashing SNMPGET.EXE entries every few seconds. I've tried killing the tasks but they keep showing back up.  The only cure I can find is to reboot the server. This is OK for a one-off issue but not 7-8 servers at a time.  Has anyone else seen this and know of a way to correct it? 

  • Hi  

    Interesting, I see that you did create a ticket similar to this issue previously.

    However, it looks like the root cause was never found and was not identical to what you are reporting here.

    I would recommend creating a follow-up ticket to further investigate this in detail.

    This appears to be very sporadic and inconsistent behavior from your reports.

    May I ask if you are using Classic Monitor > SNMP or is there a specific reason you have SNMP Enabled on the Discovery scan? 

  • Hi LRobertson,

    let me know your findings as I'm also having some issues with the discovery module which haven't been solved for the moment.


  • Hi Nicholas,

    I am using the discovery scan as a way to check hourly (as that is the smallest increment possible) for any other network devices added that we may not be aware of.  If there is a better way to do that, then please let me know.  

    Regarding the prior ticket, after further troubleshooting, I found multiple instances of nmap running (stuck actually) that resolved the issue once killed and with out a server restart.  For this current batch of issues, nmap is not what I am seeing, snmpget.exe is what shows now.