Problem :-

After installing Kaseya server on 64 bit Windows, get message:

"Connection to the database failed.

SQL 2000 prohibits remote access to the database with Service Pack 3 installed.
Verify you have SP3 for SQL2000 installed on your server"

Cause :-

Kaseya requires IIS to be running in 32 bit mode

Solution: -

Below are the instructions to set IIS to run in 32 bit mode:

1.Click Start, click Run, type cmd, and then click OK.

2. Type the following command to enable the 32-bit mode:
cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 1

3. Type the following command to install the version of ASP.NET 1.1 and to install the script maps at the IIS root and under:
%SYSTEMROOT%\Microsoft.NET\Framework\v1.1.4322\aspnet_regiis.exe -i

4. Make sure that the status of ASP.NET version 1.1.4322 is set to Allowed in the Web service extension list in Internet Information Services Manager.

http://support.microsoft.com/default.aspx/kb/894435


Legacy Forum Name: Unable to connect to database on Windows x64,
Legacy Posted By Username: dwalsh