Kaseya Community

Moving DB Server

This question is not answered

Maybe I missed this in the documentation...

 

We will be moving our database server from one network to another network.  Its the same server and data, but we will have to change the IP information assigned to the interfaces on the box.

I can find in the install guide where this is possible with the app pretty easily.  However, with the DB in accessible, how will I be able to get into the VSA to do the "Change DB" that would normally allow you to change the database configuration?

I will need to point the VSA to its the database's new location once I have the DB online in its new home.

Does anyone have any experience with this?

Please let me know.

All Replies
  • If the SQL Server is off-line, you can still log into the VSA server. To change the IP Address of the SQL Server, go to the System Tab ->Configure. Toward the Top half of the Configure page, you will see a section which has a button named Change DB...., that is the button to change the ip address of your SQL Database server. Click on the button and make your changes. Don't forget to check and change the Microsoft Reporting Services

    Early this week we moved our SQL Server from an older server to a new machine HyperV VM server with 2.5 times more memory and our VSA response in all aspects including remote control connections is much faster.

  • Marcb,

    Thanks for posting.  I tried this on my test system.  It didn't log me into the VSA as expected.  In fact, it doesn't allow me the login page at all so much as simply prompting me to connect the DB.

    Do I need to do this from the localhost ( KServer side ) or access another internal page?

    Please let me know your thoughts.

    Thanks!

  • I don't get to the login page as well.  Is there another way to login to get to the config page?

  • You need to be in front of your VSA server and not connecting using any remote control software. If you are at your VSA Server, you should be able to log in and follow the directions I posted above. Make sure you are the Master Administrator and have the proper rights to make these changes otherwise the options will not provide you with access.

  • I have exactly the same issue.

    In preparation of upgrade to 6.5 I wanted to move the SQL from my 2005 box to my 2008 to meet the requirements of 6.5.

    Backup went ok. Restore went ok but once I pressed the CHANGE DB from the Kaseya interface I got many SQL Errors (of objects that already exists etc).

    Kaseya would not start any longer and the interface would just flash and not allow me to login any more.

    Now I wanted to point Kaseya to the old server since moving to 2008 did not work out, but I could not log on anymore so I clicked to the DB Reset page (with localhost)

    (but that did not work and it just hangs).

    So I have extracted from a Kaseya installation backup the KServer.ini and moved it to the respective folder (from the logs kserver.exe connects now but the entire Web Interface still wants to log on to the failed new Database).

    Kaseya is on a VM (so I am "in front" of the machine).

    At this point I am out of options and I have no idea how to make the Web Page connect back to the old DB (taken from a backup before attempting to move to the new server).

    Our Kaseya is totally down. I opened a Ticket with the support and I got a quick answer asking for a remote. I provided the access to the Support and now it's almost 4 hours without any feedback.. :-(

    I can't see where those database settings for the VSA can be.. I searched the whole hard disk, registry, everything.. restarted SQL Server, Kaseya Server.. nothing.

    Do you think the only thing left is to re-install everything from scratch?

    It was supposed to be an easy operation like backup - restore - click button and it turned out to be a nightmare..

    Anyone that has an idea that does not involve a full re-install would be appreciated.

  • It sounds like things are not completely syncing between all areas of the DB and App side.  You likely have some areas of the VSA that are not talking with the right information to the database side of things.  If you call support and describe the situation, they can make sure that all aspects of the VSA are using the correct DB connection info.

  • Hello mech_fan,

    Yes, turned out that in order to get the second part of the connection string setting there's an utility that can output it into a text file and can also load it from a text file.

    I don't think that the tool to generate a password compatible for this text file is included in the installation so when stuff like this happens, there's no way to fix it unless someone from support remotes in the installation.

    The thing that may help though is to use the tool to backup the connection string before running the ChangeDB.

    iisinit a.txt vsaConnStr

    That would dump inside a.txt the connection string used by the current kaseya installation.

    Note that kaseya.ini and this file use a different encryption (so that password cannot be copied / pasted between files).

    Anyway, once they have reset the password and server manually using their utility it all worked ok.

    Now they offered to do the upgrade manually (cause the automatic routine may put the state of the installation in an unrecoverable way as I discovered), and hopefully it will all be ok.

  • Hi,

    I also tried moving the DB to another sql instance on the same server but as soon as I "Change DB" to point to the restored DB on the new SQL instance, it kicks me out of Kaseya and won't let me log back in.

    Its a VM, so I did a snapshot before the "change db" and was able to go back to the old DB connection.

    Is the only option to move the DB is to contact Kaseya Support?  Anyone else have better luck moving the DB themselves?  could you list out the steps other than the one in the online help?