Kaseya Community

Kaseya on RedHat and backup options

This question has suggested answer(s)

Hi All

2 quick questions

1. Installing Kaseya agent on redhat - I've had one of my tech's try to get a kaseya working on a redhat machine but he's been having problems. Any tips or areas he might be going wrong? See his notes below.

2. Assuming we can get kaseya working on redhat (as I believe it is listed as being supported), then what would everyone recommend to use for backups which would report back to kaseya for alerting etc, seeing that BUDR doesn't support linux?

Thanks all.

"RHEL4 x64 test server - I have spent the last 2 days working on this

I can honesty say I have been trying nearly everything under the sun to get Kaseya onto it and working 

 

The problem is that the kaseya shell script installer for the agent needs the following 

 

ia32libs specifically 

YUM or APT if you are using a debian based distro 

PERL – Easy and works fine

 

The script is written for versions of RHEL5 / CentOS4.x which both support the YUM package management system. Currently the system in use is the up2date system which queries RH for all install critical and non-critical security updates as well as binary packages and requires a subscription to access them. 

 

So I thought I would attack it sideways and install yum on rhel4 which is certainly possible…. BUT

It nearly broke all the repo's for RH – I highly doubt clients would go for this

 

Ok so I thought what about the following 

Migrate to Centos4 – Yeap this works but rebrands the entire system and causes major headaches to get RH updates and half broke up2date and some of yum stuff kept getting corrupt headers. It was pretty bad and I would not want implement this. It didn’t attempt to install the agent since it was 50/50 working 

 

So what I have not tried 

Migrate them to RHEL5/6 which would require a new subscription both of these are supported by Kaseya, RHEL4 is getting pretty long in the tooth too

Entirely possible though 

I would not recommend them going over to centos5.x  

Try something else besides kaseya to monitor the server?

 

All Replies
  • Hi,

    Sorry I never saw this. Did you ever resolve this? The Linux agent supports both RHEL and CentOS versions 5 and 6. We've never tested on older versions than 5. Hopefully you're tech's suggestion of upgrading did the trick. I run an agent on RHEL 6 on a daily basis. Before the release of RHEL6, it was a 5.x system so that also works. But it does rely on yum to install 32-bit libraries.

    Gordon - Linux development team