Kaseya Community

Install SSL certificate on VSA

  • Okay, I have upgraded to kaseya 9.3 from 9.2 is working well after some quick fixes by support.

    I am on the current patch release and I wish to install a new SSL certificate. I see for version prior to 9.3 you used jave to install the certificate on the kaseyaedgeservices, but I cannot see how this is now done as the java command does not work. I have searched the howto and knowledge base but cannot find anything, I remember hearing that they had moved from java to a c++ program so I presume there is a new method.

    Can anyone point me in the right direction?

  • I haven't installed 9.3 yet, but according to the instructions here: helpdesk.kaseya.com/.../58305257

    There is supposed to be a "SSL configuration Tool" under Start->Programs->Kaseya"

  • Hi  

    You should see something similar in your system:

    Running the command in the KB: https://helpdesk.kaseya.com/entries/58305257

    Should open the KAF Certificate Manager Utility - this is still java based as only the application firewall itself was re-written to C++ in the 9.3 release:

    If you have tried all of these steps and they do not work, please create a support ticket and send me the number.

  • Nicholas - I ran the command line util and  it needs to be java -jar kastool.jar --importui . it need 2 minus signs to work.

    Fixed a spelling mistake in previuos post.
    [edited by: Adrian at 5:33 PM (GMT -7) on Jun 22, 2016]

    To confirm - you were able to run the command successfully and deploy your SSL certificate?

  • Thanks Nicolas, Yes I run the command line, I got the syntax wrong a copy of times but it worked well. The short I have now edited with the same command line and it works so good finish.