Kaseya Community

Cannot upload an MSI file to Kaseya

This question is answered

The file disappears every time. I did add it to the white list settings.

Any thoughts?

Thanks!

Verified Answer
  • emartens

    Have you made an exception for this directory in your antivirus software? It could be removing the msi as a false positive.

All Replies
  • Hi  

    To confirm, are you trying to upload an MSI to Agent Procedures > Manage Files?

    Does it successfully upload? 

    Are you running VSA Hosted (SaaS) or On-Premise?

  • Hi

    Thanks for replying. It does successfully upload, but it is gone by the time I go to search for it in the script. We are running on premise vsa

  • This happened to me too, I discovered it was down to pushing up an .msi to the Kaseya server that is actually in our DMZ from a PC in the corporate LAN.

    If I pushed the .MSI up from the actual server it was fine.

    Stuart



    Typo
    [edited by: stukinnear at 9:13 AM (GMT -7) on Aug 16, 2016]
  •  

    Check locally on the Kaseya Server in C:\Kaseya\WebPages\ManagedFiles\VSASharedFiles if the .MSI is there.

    If its not, you could also try and place the file manually in this location and see if it stays.

  • Hi  The file does not stay when I copy it to that directory.

    Thanks

  • emartens

    Have you made an exception for this directory in your antivirus software? It could be removing the msi as a false positive.

  •  

    I would recommend what  referenced.

    If you do not have any AV -- do you have any security programs, firewall, conflicting snapshots, or data mirroring that may be interfering with this?

  • Thank you for the replies. It appears Kaspersky was removing the msi file. I added the exclusion and now it seems to be working just fine. I'll have to figure out why I was not getting alerted when it picked something up, but that's another story.

    Thank you for your help.