Kaseya Community

Setting correct access rights (clicking the agent icon doesn't work anymore)

This question is answered

 Hi. I'm trying to create a new user role that can only see a few thing:

- the agent list (and filter it with views or the machine group/id)

- run procedures now.

- click for remote connect

- ctrl-click for Live connect

Within live connect  they must be able to start a procedure, go into the connect remote, and access the CMD and powershell interface.

I cant get to a good setup in the access rights of this group. Examples:

1. Remove all the functions under 'manage agents' and you can see the agent list anymore. Pretty obvious, but all those checkboxes give altering priveleges.

2. I only enabled (and everything under it): Agents>Agents>Manage agents, Liveconnect and the system things i cant disable. Now i cant click the agent icon anymore. What am i missing?

Thanks.

Maurice.

Verified Answer
  • I contacted support and they gave me the answer:

    Can you please make sure that you have assigned the below access rights to the user.

    Audit > Assets > View Assets > View

    Audit > View Individual Data > Machine Summary > Machine Status

    Audit > View Individual Data > Machine Summary > View Single Machine Interface

    Live Connect (select appropriate functions)

    Quick View > Quick Launch Functions (select appropriate functions)

    This resulted in my user seeing the Audit menu in the side menu, but they are going to have to live with it!

    The following KB article might also be helpful:

    helpdesk.kaseya.com/.../229009728-New-KLC-403-Startup-Error-Code

All Replies
  • Could you provide a screenshot as to where you may be stuck?

  • Goodmorning Oscar (and other readers),

    These are the settings I want for this user role with some little adjustments in the quick view.

    Manage agents:

    The rest of the access rights (each tagged box has all subboxes tagged as well):

    The actual issue:

    Extra info: I tried changing the role type from VSA Admin to End user and back. I tried enabling all the rights to Manage agents, didn't resolve the issue.

    Which tagbox controls the 'clickability' of the agent icon?



    .
    [edited by: Maurice at 12:51 AM (GMT -8) on Jan 18, 2019]
  • When I want someone to see something but not have any other access, I first de-select the topmost setting (Manage Agents) to clear all settings, then I select any item below that topic (Delete Agents), then de-select that same sub-topic. This has the result of selecting the top-most item but no sub-items are enabled.

    We have a Level-0-Support role with many of these type of selections, and it's designed for non-technical staff to get counts, status, reports, etc. without having any management or administration rights.

    I'm defining a new role later today - I'll identify your specific setting for remote-control and post later.

    In the Downloads/Documents page of our website are Tech Briefs - one of the documents is related to setting VSA Security Roles. We have several numbered roles that are assigned to office admins, Technicians, Specialists (limited VSA administration), and VSA Admins. Nobody has Master role/scope in our org, and this document explains how we set it up. Access to this page does require creating an account on the website. You might find that document helpful as well.

    Glenn

  • Thanks Glenn, later today I will check your explanation and if it works the same for my environment. Looking forward to your conclusion as well.

  • That tagging and untagging 'trick' works well! Does exactly what it must do. But now the big question. which tagbox controls the 'clickability' of the agent icon?

  • I contacted support and they gave me the answer:

    Can you please make sure that you have assigned the below access rights to the user.

    Audit > Assets > View Assets > View

    Audit > View Individual Data > Machine Summary > Machine Status

    Audit > View Individual Data > Machine Summary > View Single Machine Interface

    Live Connect (select appropriate functions)

    Quick View > Quick Launch Functions (select appropriate functions)

    This resulted in my user seeing the Audit menu in the side menu, but they are going to have to live with it!

    The following KB article might also be helpful:

    helpdesk.kaseya.com/.../229009728-New-KLC-403-Startup-Error-Code