Please be advised that Kaseya Backup (BUDR) 3.2 is now available on an as needed basis for customers requiring the following enhancements:


  • Support for Windows 7
  • Support for Windows Server 2008 - R2
  • Support for Acronis 9.7-8319 which addresses VSS technology issues
  • Mounting Backup Selection - allows customers to specify drives

Installing Kaseya Backup 3.2 on your KServer does not require that you upgrade all of your endpoints. You should upgrade only the endpoints that require the enhancements provided with the Kaseya Backup 3.2 release.

NOTE: Acronis 9.7-8319 no longer supports a local User Interface (UI). If you are reliant on the Acronis UI, you should NOT upgrade at this time. A subsequent Kaseya Backup release will be available in the next few weeks which will include a new Kaseya Local UI.

Please visit the Kaseya Download Center at http://www.kaseya.com/support/Downloads.aspx for the Kaseya Backup upgrade.

Thanks from your friends at Kaseya!

Legacy Forum Name: Backup and Disaster Recovery - Update!,
Legacy Posted By Username: kaseya