Kaseya Community

Kill/Restart a stopped service

  • I'm new to Kaseya and have actually spent a bit of time on this website looking for the answer but I haven't found the answer I was looking for yet. We have a 64b Exchange 2007 that has an unresponsive agent. Can't touch it. Locally I've tried to restart the service, and it just errors out with a "did not respond". I've tried using taskill and pskill on the agentmon,exe figuring that would allow me to restart the service, but even with them returning a positive, the agentmon.exe task is still running (with the same PID, so it likely never did terminate)

    I'm just trying to figure out (aside from rebooting) is there a way to bring all-Kaseya to a halt and bring it all back up again (when it's not exactly cooperating).

    Any help would be greatly appreciated.

    Legacy Forum Name: Kill/Restart a stopped service,
    Legacy Posted By Username: sshoots
  • Try taskkill /f /im servicename.exe (where servicename.exe is the name ofthe service you are trying to kill) to kill a service. I don't recall ever having a problem with using this to kill any service on Win2K3 and Win 2k8 boxes.

    If this does not work, the only other thought I have is you are using an account that does not have permission.

    Legacy Forum Name: How-To,
    Legacy Posted By Username: boudj
  • I've just had this problem too. Only way I could think was to remote into a client PC after I lost contact with the server from Kaseya and schedule a restart of the server overnight. Agentmon.exe just would not disappear despite taskkill saying it had stopped it.

    Legacy Forum Name: How-To,
    Legacy Posted By Username: wodger
  • We have just started having this issue in the last weeke as well. The Agents all seem to die shortly after the Latest Audit Job runs. In some cases I have simply been able to access another server and start the service back up, but on 2 different Machines at different client sites I have had the AgentMon.exe stuck in the Task Manager reporting via taskkill and pskill that the process was terminated, but not able to start the Kaseys Service. I looked for some other Kaseya services (KasUsrTsk.exe was the only other one I found on 1 occassion) and stopped it successfully but it did not help. So far a Reboot is the only thing that fixes the issue. Wondering if a patch in the last week is contributing to it (either MS or K). So far I have seen the Stuck AgentMon on Server 2003 R2 SP1 and SBS 2003 SP2. July 28th was my first encounter with this

    Legacy Forum Name: How-To,
    Legacy Posted By Username: mreid@networkingresults.com
  • Don't ask me why, but in my case it can't be recent MS patches Red Faced



    In all but one of our four cases, the machine has very recently had Trend Micro Worry Free Business Security 6 Advanced installed and is the Trend server for the network. The last one is an XP box running a blackberry server. A common element is Trend's behaviour monitoring. Another common element seems to be exchange as system manager in installed on the blackberry box but I think other people are seeing several machines going offline which presumably arent' all running system manager..



    See this too:

    http://community.kaseya.com/xsp/f/114/t/5069.aspx

    Legacy Forum Name: How-To,
    Legacy Posted By Username: wodger
  • I've been trying to find a way to stop the Agentmon.exe process from Task Manager but unable to.

    The problem is the Agent is offline, making us think the server is down, but we can remote into it from another server, so in fact the Agentmon process has hung. I can't stop the Kaseya service in Services, but Agenmon.exe is still running in Task Manager and I can't stop it from there. So because of this, the Kaseya service cant' be started up again.

    I've tried Taskill.exe and PsKill.exe and both reported that it has stopped successfully, but Agentmon.exe is still running in Task Manager.

    Hopefully someone can find a solution that doesn't require a restart of the server. The only solution is to restart the server at the moment.

    Legacy Forum Name: How-To,
    Legacy Posted By Username: binh.tang
  • Good day Forum,

    We have been experiencing this similiar problem for months. It was always easiest to just reboot the server rather than investigate but I finally decided today, after the Kaseya agent running on our VSA hung, that it was time to tackle this problem.

    The machine specs of the server exhibiting this problem are as follows:

    O/S: Windows 2003 Enterprise SP2
    CPU: Virtual, Intel Xeon E5430 @ 2.66GHz
    RAM: 3GB
    Windows Updates: All microsoft critical and high priority updates.

    As with other posters above, I was unable to use PSKill or Taskill to terminate the AgentMon.exe process. Although both did not return any errors, the PID did not change on the process.

    I ran the SysInternals utility Process Explorer to identify if the AgentMon.exe process was still performing any work in the background. After 5 minutes of monitoring I was confident that the process was dead.

    I then checked what file handles were being used by the AgentMon.exe process. There were several still open, unfortunately I did not record that data before terminating each file handle, one at a time and testing if I could end the AgentMon.exe process. However, I was still unsuccessful at ending the AgentMon.exe process even after all file handles were terminated.

    I then used another SysInternals utility, Process Monitor, to find if there were any threads still in use by AgentMon.exe. I did find one and the only info I have on it is as follows:

    Thread ID: 2188
    Start Address: !MulDiv+0x120
    Start Time: 7:03:42 PM 02/3/2010
    State: Wait:UserRequest
    Kernel Time: 0:00:00.000
    User Time: 0:00:00.000
    Context Switches: 6

    I attempted to kill this thread through Process Monitor, however it told me access is denied. I checked permissions on the thread and only SYSTEM had full control. I was unable to take ownership.

    The fix at the time, a band-aid, was to change the Kaseya service to run under an administrative account and restart the service, thus creating a new AgentMon.exe process. This was our only option as we can not reboot the Kaseya VSA mid-day.

    I'll send the same information to Kaseya support and update this thread as I receive more information.

    Legacy Forum Name: How-To,
    Legacy Posted By Username: ssi.jball
  • Ever tried to simply re-install the agent?

    Legacy Forum Name: How-To,
    Legacy Posted By Username: XeviouS