Kaseya Community

Remote Control Issues

  • Hey Guys,

    Not sure if this is the right place to post this, I've already contacted support without much help so far.

    We're experiencing massive (global across all clients) issues with remote control. Neither K-VNC or RDP work in a specific scenario. We've got the issue narrowed down, but have no idea how to fix it. Here's the problem:

    If there's a user currently logged into a system, we cannot remote control that system via Kaseya. It just times out and goes to that "this system is too busy" message. If we access that system by other means (say remote to another server, and then RDP from that server to the one we actually want to get to), we can access it no problem. If we disconnect and log the logged in user out, all of a sudden Kaseya Remote Control works again.

    If we leave a user logged in and disconnect, and then try Kaseya Remote Control again, we can't connect and get the same error.

    Does anyone have any experience or suggestions with this? It's severely impacting our ability to use Kaseya.

    Thanks,
    David

    Legacy Forum Name: Remote Control Issues,
    Legacy Posted By Username: davidb
  • Hi David,

    which version of K are you on? 2008SP1 or K2?

    We did not have this problem with K2008 at all we've been running on K2 for 4 months now and we don't have this issue either.

    are the machine spec recent?
    what OS / SP's do those agents run on?

    Legacy Forum Name: How-To,
    Legacy Posted By Username: Hans den Boer
  • We're on 2008 SP1 - 5.1.0.0.

    It's a very odd problem, we thought it was isolated to 2008 R2 boxes, but it's widespread and confirmed on WinXP SP2/3, Server 2003, Server 2003 R2, Server 2008, Server 2008 R2.

    Legacy Forum Name: How-To,
    Legacy Posted By Username: davidb
  • strange
    i assume your K server is fully hotfixed etc etc

    sounds like to "logged on user" is blocking something. i assume you've checked the logs, right?

    did you run process explorer on the servers when a user was logged on to see if the k agent did get requests? do you see any reuqest coming from your k server when you sniff with ie whireshark?

    Legacy Forum Name: How-To,
    Legacy Posted By Username: Hans den Boer
  • We are fully hotfixed, and I'm not getting much from the logs.

    We'll try out Process Explorer / Wireshark and let you know!

    Thanks.

    Legacy Forum Name: How-To,
    Legacy Posted By Username: davidb
  • I've got a couple of servers that have that same issue. There is a registry setting that explicitly denys RDP that needs to be fixed (sorry I dont have a link handy), as for the (k)VNC issue... silly question did you check the firewall?

    Legacy Forum Name: How-To,
    Legacy Posted By Username: thirteentwenty
  • registry settings for TS:

    To enable Remote Desktop remotely by using the registry
    1. On any computer that is running a version of Windows Server 2003 or Windows XP Professional, click Start, click Run, type regedit, and then click OK.
    2. On the File menu, click Connect Network Registry.
    3. In the Select Computer dialog box, type the computer name and then click Check Names.
    4. In the Enter Network Password dialog box, provide Domain Admins credentials for the domain of the server, and then click OK.
    5. After the computer name resolves, click OK.
    6. In the computer node that appears in the Registry Editor, navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server.
    7. In the console tree, click Terminal Server and then, in the details pane, double-click fDenyTSConnections.
    8. In the Edit DWORD Value box, in Value data, type 0, and then click OK.
    9. To implement the change, reboot the server remotely, as follows: Open a command prompt, type the following, and then press Enter: shutdown -m \\ DomainControllerName -r

    Legacy Forum Name: How-To,
    Legacy Posted By Username: Hans den Boer
  • Hans den Boer
    registry settings for TS:

    ...
    9. To implement the change, reboot the server remotely, as follows: Open a command prompt, type the following, and then press Enter: shutdown -m \\ DomainControllerName -r


    that should read reboot the target machine

    and i would use the following:


    shutdown -m \\ -r - t 00

    taht'll reboot immediately

    Legacy Forum Name: How-To,
    Legacy Posted By Username: thirteentwenty
  • Just a silly question, but you said it only happens when there is a user logged in already. Did you make sure there are no Machine or Admin Policies connected through Kaseya that is prompting the end user for permission? I've had that catch me occasionally.

    Also, I've see the TS registry key take effect after 10-15 minutes of the remote server just sitting there. No reboot needed.

    Legacy Forum Name: How-To,
    Legacy Posted By Username: CCDave