Kaseya Community

Uninstall Agent after Account is deleted

  • We have several accounts which were deleted months ago but the Agent not uninstalled. I would now like to uninstall the Agent, but do not have physical access to the machines. Is there a way to do this?
    Thank you.

    Legacy Forum Name: Uninstall Agent after Account is deleted,
    Legacy Posted By Username: masselin
  • The response from Kaseya support was to manually uninstall the agent, using this procedure: manual removal but add /silent so it is transparent to users.

    My issue is that this is for a customer with several locations, some of which I do not have access to. They don't have an internal IT person if something goes wrong.

    I've tried reinstalling the agent in order to recreate the account but that has failed.

    I know the agents are still there because in Install Agents in LAN discovery (Agent tab), they show that the install package ran and that they last checked in today.

    Has anyone found a workaround for this?

    Legacy Forum Name: How-To,
    Legacy Posted By Username: masselin
  • You've tried the Delete option under the Agents module?

    I've had a similar issue where I keep "deleting" the agents, but they keep reinstalling again and again. The only thing I've been able to sucessfully do is change the primary and secondary check-in values to a different IP. This will prevent the agents from checking into your server again.

    Legacy Forum Name: How-To,
    Legacy Posted By Username: CCDave
  • Thank you for your response.

    I cannot uninstall/delete the agents under the Agents module because these workstations do not appear there (the accounts were deleted using the "delete account now without uninstalling the agent" option). All I have showing in that module are the servers, which should be there since we are still monitoring them.

    I don't mind the agents checking in, I can happily ignore that (until I need the licenses!) but our customer wants the agents uninstalled from the workstations.

    Confused

    Legacy Forum Name: How-To,
    Legacy Posted By Username: masselin
  • If the agents are actually installed and running on the workstations, they should recreate themselves. If they are not recreating themselves, then they are not running on the workstations. (Maybe the service is disabled even though the program is still installed.)

    I'm not sure how you can remove a program from a machine that the agent is not running/checking in, nor that you have access to anymore. (Unless I'm missing something.)

    Legacy Forum Name: How-To,
    Legacy Posted By Username: CCDave
  • The users get an error that the agent cannot connect to the server.

    I cannot see the workstations all at, except for in LAN watch.

    Legacy Forum Name: How-To,
    Legacy Posted By Username: masselin
  • First off, when is your LAN Watch scheduled? Are you looking at old data?

    Second, I've never heard of a user getting an error stating "Cannot connect to server". I know the agent icon will go "offline", but I've never heard of a message.

    Third, it sounds like your K server is still set with the machine groups for this customer. Check under System -> Check-in Policy and make sure you have the "Allow automatic account creation" option enabled for the machine groups in question. This may be what is blocking the agents from coming back "online".

    Legacy Forum Name: How-To,
    Legacy Posted By Username: CCDave
  • Thanks again! Smile

    My LAN watch runs every day, the last time being this morning at 9:30.

    I've asked my contact for more details, but apparently the "error" is that the icon in the system tray says the agent cannot connect. You are most likely correct and it shows as offline. This was one of those "make it go away, I do not want to talk to you about it" conversations.

    I have now checked the "Allow automatic account creation" in the System tab - thank you, I knew there was an option somewhere and I couldn't for the life of me find it!

    Now for the waiting part...

    Legacy Forum Name: How-To,
    Legacy Posted By Username: masselin
  • masselin
    The users get an error that the agent cannot connect to the server.

    I cannot see the workstations all at, except for in LAN watch.


    I have seen that error with VNC but never with the Agent. IDK if backing up and restoring to an earlier date temporarily would be an option to get those accounts back and then restore back to the current db.

    Legacy Forum Name: How-To,
    Legacy Posted By Username: mattb@ghentcomputer.com
  • I've seen the "cannot connect to server" error when we first started using Kaseya, the there was a routing issue that caused it.

    Legacy Forum Name: How-To,
    Legacy Posted By Username: thirteentwenty
  • If you're still managing the servers, could you use a GPO to correctly install a new package? Use the overwrite switch (/r) in a new package that dumps into a special "delete me" group. From there you should be able to "uninstall at next checkin" safely.

    Alternatively, you could RDP from the server to the affected machines and manually disable the agent, if there aren't too many.

    There's probably a way to do it using a vbscript as well, delete the startup key for K (current version/run), delete the files, and you're good to go. Again, a simple GPO could deploy this.

    If they aren't using a DC then you'll probably have to remote in.

    Legacy Forum Name: How-To,
    Legacy Posted By Username: dwujcik