Kaseya Community

vPro how-to

  • Does anyone have an how-to or qick start to use vPro ?

    Legacy Forum Name: vPro how-to,
    Legacy Posted By Username: pdepuydt
  • When you go to the Agent tab you will see under the Lan Watch function a checkbox where you enable to scanning for V-Pro and put in your username/password for connecting to it. Is this what you was looking for?

    God Bless,
    Marty

    Legacy Forum Name: How-To,
    Legacy Posted By Username: Missing Link
  • Hi,

    Thanks for the answer but no, that I found Smile
    I even read the respective help file Wink

    I'm under the impression that on the vPro client side something
    has to be done as well ... say like snmp. I have several vPro machines
    but they don't show up, hence there is a communications glitch.
    It looks a lot like snmp probs when you do not enter the public community
    password.
    I didn't a lot of time on it yet, just thought to see if there is an how-to
    before I reinvent the wheel ... you get the pic.

    Thanks,

    Legacy Forum Name: How-To,
    Legacy Posted By Username: pdepuydt
  • I'm having this same problem...so either there is something that is wrong or we don't fully know how to set it up. I'm guessing the latter.

    The info on it is very sparse. I'm really looking forward to getting this going.

    Legacy Forum Name: How-To,
    Legacy Posted By Username: jasonb
  • vPro is the "desktop" name for Intel's AMT - http://en.wikipedia.org/wiki/Intel_Active_Management_Technology

    Basically, the short of it seems to be "you have to enable it in the system bios"

    So, for existing networks, it may not be such an amazingly awesome discovery breakthrough. Since we haven't yet updated to 5.0 ourselves I can't say for sure, but it seems like it might still be useful to go through your network manually and "turn it on" - just to be able to turn on machines to do midnight maintenance on your managed network.

    Also to be determined: will it work with Enterprise mode? My bet is not, since that mode requires certificate-signed communications, but again, time will tell!

    Legacy Forum Name: How-To,
    Legacy Posted By Username: Matthew Bartels
  • Yes, you need to configure vPro/AMT in the BIOS before you can discover a vPro machine with Kaseya. This is the step where you would set the vPro/AMT credentials for the first time (among other important settings). Intel has a Configuration Guide that describes the process. Here is a link to the guide:

    http://communities.intel.com/docs/DOC-1429

    Intel supports a "Small Business" mode, and an "Enterprise Mode." Refer to the Intel Configuration Guide and other related Intel materials for details.

    For "Small Business" mode, it is wise to use a common user name and password for all machines on a particular network (much like having a common standard for a local administrator account on Windows machines).

    Legacy Forum Name: How-To,
    Legacy Posted By Username: kaseya
  • Thanks for the info,

    This is exactly what I needed, will see how far I get now :-)

    Legacy Forum Name: How-To,
    Legacy Posted By Username: pdepuydt
  • I was able to enable it and can now access it via a web browser.

    I doesn't say this anywhere but the default 'username' is 'Admin' as well. not just the password.

    One thing to remember is you can not connect to the same computer you are are at. It seems to only work from another computer.

    Also, you can't seem to access it by the IP of the workstation as the vPro stuff grabs a different IP. I had to use the hostname I entered during setup. Once I was able to log in and see what IP vPro had been given I was able to connect by IP then.



    Now to get LAN Watch to find them.....

    Ok, LAN Watch now sees the computer....just takes longer then I thought it would so be patient.

    Legacy Forum Name: How-To,
    Legacy Posted By Username: jasonb
  • The vPro section of the BIOS will sometimes grab a different IP from your DHCP server. The trick is to set a reservation on your DHCP server for that machines MAC address. Found that out the hard way!

    I had a DVR server that had a static IP address. Every time I attempted to access it through it's host name, it redirected to an IP that didn't exist. Did a quick check and the server's DNS had logged a different IP address for that PC's host name. I manually changed it to the static IP address and it fixed the problem. A few days later they lost connectivity to the DVR again. I immediately checked the DNS and it had changed back to a strange IP. I checked DHCP and it was handing out an IP address to my DVR even though Windows had it set to a static IP address. Once it handed out the IP, it automatically updated DNS. Took a bit of sleuthing, but I finally figured out that each time the DVR was restarted, the Intel AMT (vPro) was asking for a DHCP address from the server, while Windows had a static! What fun! Eek

    So, you could either set a static IP for the Intel AMT that is the same as your Windows static IP, or set a reservation in your DHCP server, and that will ensure that you don't end up with two IPs for the same machine.

    Legacy Forum Name: How-To,
    Legacy Posted By Username: jbellflowers
  • In the last post it was stated that vPro uses the same hostname and caused an issue with DNS in that way. But should one not use a different host name, like hostname-AMT instead?

    In that way if the Intel AMT has a different IP adress there are no isues with DNS. Or am I wrong.

    I will be starting to test with vPro this week.

    regards

    Arne

    Legacy Forum Name: How-To,
    Legacy Posted By Username: arne.vanbalgoijen@4TX.be
  • arne.vanbalgoijen@4TX.be
    In the last post it was stated that vPro uses the same hostname and caused an issue with DNS in that way. But should one not use a different host name, like hostname-AMT instead?

    In that way if the Intel AMT has a different IP adress there are no isues with DNS. Or am I wrong.

    I will be starting to test with vPro this week.

    regards

    Arne


    The instructions says to set it the same as the host. The only time I think you will have issues with getting a different vPro IP address will be with computers that have Static IP addresses set manually. Otherwise it should work normally. That was my problem. I have my PC setup manually and not through DHCP like I should have.

    So it will just be forcing us to do things correctly I guess Smile

    Legacy Forum Name: How-To,
    Legacy Posted By Username: jasonb
  • Tried vPro today on a HP DC7800. It took me a while to figure out what different settings mean and what is needed to do to get things working for Kaseya. This is what needed to be done and seems to work:

    To access vPro settings: Ctrl-P during POST
    Default password: admin

    Auto Change Password:
    Enter a new password: Minimum 8 characters with upper and lowercase, 0-9, and one of !@#$%^&*()

    Setup Intel ME Configuration

    Power Control
    Power setting: Desktop: ON in S0, ME WoL in S3, S4-5
    (S3 Standby, S4 Hibernate, and S5 Off)
    (In our case: No power on after Power Loss for standard workstations)

    Setup Intel AMT Configuration

    Hostname = OS Machine Name

    TCP/IP
    Keep DHCP ON when OS has also DHCP enabled
    Domain = Customer's Domain Name

    Provision Model: Change to SMB (Standard is Enterprise)

    Test Configuration:
    Access machine through: http://hostname:16992 from a different machine. The username is admin

    Start a Lan Watch with Vpro scan enabled. Username is admin
    Control of the machine from Remote Control -> Power Mgmt

    Regards, Edo

    Legacy Forum Name: How-To,
    Legacy Posted By Username: Edo Albers
  • Thanks for posting that, Edo! It's perfect -- just what we need, all the key information, without a lot of blather. Why Intel or Kaseya couldn't have posted it is beyond me.

    /kenw

    Legacy Forum Name: How-To,
    Legacy Posted By Username: Ken Wallewein