Kaseya Community

Report Failing

  • When trying to run certain reports, for example a patch management summary, we receive the following error

    Error: The session identifier is missing. A session identifier is required for this operation. ---> Microsoft.ReportingServices.Diagnostics.Utilities.MissingSessionIdException: The session identifier is missing. A session identifier is required for this operation.


    The kaseya server is able to communicate with the sql2008 server with no issues, has anyone run into this before?

    Legacy Forum Name: Report Failing,
    Legacy Posted By Username: Khoel@smsprotech.com
  • Yes - we had exactly the same problem.

    In our case the problem was caused by haveing the AVG Client components installed on the server. It was odd as it only affected some reports, but the Patch Management report was one of them.

    If you have AVG installed on the Report Server try disabling it and then re-running the reports. If that cures the problem you will need to uninstall AVG and then re-install minus any client components (Yes I am not sure why it lets you install client components on a Server either, but that's another story)

    If you dont have KES or any other AV product on the report server then I would raise a support case. Thats how I got my reports fixed - they did a good job turned the thing around in a couple of hours.

    Legacy Forum Name: IT Procedures,
    Legacy Posted By Username: PeterS
  • The AVG was not the issue. I have raised a case with Kaseya and they have been somewhat slow on helping resolve the issue as it is still happening.

    Legacy Forum Name: IT Procedures,
    Legacy Posted By Username: Khoel@smsprotech.com