Kaseya Community

Kaseya over proxy using TCP port 443

  • Guys, does anyone have Kaseya running successfully through a proxy on TCP Port 443?

    We've signed up a client but their internet traffic is routed through a proxy in Germany and due to corporate policy they won't allow an exception for Kaseya....help!

    Legacy Forum Name: Kaseya over proxy using TCP port 443,
    Legacy Posted By Username: tbone2345
  • There is a EasterEgg proxy link on the Agent tab just below the Update Agent menu. Press and hold Ctrl on the while space just below and it will show you a Proxy Settings page for your nodes. Hope this helps.

    Legacy Forum Name: MSP General Discussion,
    Legacy Posted By Username: jchurch
  • I'm not clear on what setting the proxy (using the Easter Egg link) will actually do. Will that tunnel what normally goes out on port 5721 through the proxy (preventing the need to open up 5721 outbound)??

    If not, please enlighten me. I just stumbled upon this post looking for a solution to a different problem. Any other easter eggs??

    Thanks,

    Gene

    Legacy Forum Name: MSP General Discussion,
    Legacy Posted By Username: xogent
  • Brilliant!! Has anyone used this feature?

    As part of industry Regulations, we require all of our sites to use proxy services for any back-end servers. I am hoping that we are able to use this proxy function to successfully meet requirements.

    Legacy Forum Name: MSP General Discussion,
    Legacy Posted By Username: sam.taylor
  • I have used this and it does work.

    Legacy Forum Name: MSP General Discussion,
    Legacy Posted By Username: mlnetcor
  • Just to raise this old dog.

    How do you set proxy settings for agents you are deploying.

    If the agent will not check in how can you tell it to go through a proxy server.

    If that makes sense.

    Michael

    Legacy Forum Name: MSP General Discussion,
    Legacy Posted By Username: mmartin
  • Just had a quick look through all of the configuration files for the clients that we use a Proxy on. I cannot find an option within there.

    Try copying the settings from a template account from that?

    Legacy Forum Name: MSP General Discussion,
    Legacy Posted By Username: sam.taylor
  • Hi,

    The hidden proxy tab only controls the use of curl for various Kaseya tasks.

    I believe you can do a port mapping 443 -> 5721 on either firewall (theirs or yours) and Kaseya won't complain.

    We're moving to use 443 for Kaseya traffic - despite the protocol non-compliance issues.

    Andrew

    Legacy Forum Name: MSP General Discussion,
    Legacy Posted By Username: andrew.doull@computer-care.com.au