Problem:

When trying to setup an ODBC connection using the KaseyaViews function, The steps always fail.

Reason:

MSDE SP4 disables the TCP/IP listener. This stops any remote or local TCP/IP connections to the database.

Resolution:

Bring up a command window (start -> run -> cmd

netstat -a | find /i "ms-sql-s"

If SQL is listening you will see a result like this

TCP 46-server:ms-sql-s 46-server:0 LISTENING

If you do not see this, you will have to enable the TCP/IP listener. You can do this as follows:


  1. Click Start
  2. [/b] menu, and then click Run[/b].
  3. In the
  4. Open box, type svrnetcn.exe, and then click OK[/b].
  5. In the
  6. Disabled protocols list, click TCP/IP, and then click Enable.
  7. Click
  8. OK.
Once SQL has been restarted you can run the netstat command again as before to confirm that the service is now waiting for connections.

Please note that MSDE may not be using the standard port 1434, you may need to click the "Client Configuration" button and select the port "1433" instead of using the default "Dynamic Port"


Legacy Forum Name: Unable to connect using KaseyaViews,
Legacy Posted By Username: jnuttall