Problem:
The Kaseya system log is showing messages such as
"Too many connections (109) during high SQL CPU util (22%). Pausing for 1 seconds."

Cause:
This message means that the kaseya server is busy, and it is delaying the check-in of agents until it has become less busy.

Solution:
This often occurs if many tasks have been scheduled to run at the same time. Some Kaseya tasks such as audits and Patch scans have an impact on the Kaseya Server. If, for example, many patch scan have been scheduled to run concurrently, the data will be sent back to the server at the same time and make the server busy.

Check the system tab -> statistics, and look at the "top scripts run in the last hour" section. If you see a high number of a certain type of script running, you have possibly found the cause.
To correct this, go to the scripts tab -> Distribution. Here you will see a histogram of script activity. You can also rescheduled these script across a wider time-frame on this page. This will remove the spike in activity.


Legacy Forum Name: High CPU Usage,
Legacy Posted By Username: jnuttall