Kaseya Community

Set Pagefile to System Managed

  • Set_SysMan_PF.txt

    Hi,

    I use the following to set the pagefile to system managed. Just import the below and change the attached from .txt to .VBS. You may also want to change the folder name in the

  • <?xml version="1.0" encoding="UTF-8"?>

    -<ScriptExport xmlns="www.kaseya.com/.../Scripting" xmlns:xsd="www.w3.org/.../XMLSchema" xmlns:xsi="www.w3.org/.../XMLSchema-instance"> -<Procedure id="1999975284" treePres="3" name="Set Pagefile to system managed"> -<Body description="Install's Change Pagefiel Script to C:\qualcom and runs."> -<Statement name="ExecuteShellCommand" description="Execute the given command as if it were typed in at a command prompt." continueOnFail="false"> <Parameter name="Command" value="md c:\qualcom" xsi:type="StringParameter"/> <Parameter name="ExecuteAccount" value="System" xsi:type="EnumParameter"/> <Parameter name="Is64Bit" value="False" xsi:type="BooleanParameter"/> </Statement> -<Statement name="WriteFile" description="Write the selected file to the machine at the path specified - full path required." continueOnFail="false"> <Parameter name="Path" value="c:\qualcom\Set_SysMan_PF.vbs" xsi:type="StringParameter"/> <Parameter name="ManagedFile" value="VSASharedFiles\Set_SysMan_PF.vbs" xsi:type="StringParameter"/> <Parameter name="DeleteAfter" value="False" xsi:type="BooleanParameter"/> </Statement> -<Statement name="ExecuteShellCommand" description="Execute the given command as if it were typed in at a command prompt." continueOnFail="false"> <Parameter name="Command" value="c:\qualcom\Set_SysMan_PF.vbs" xsi:type="StringParameter"/> <Parameter name="ExecuteAccount" value="System" xsi:type="EnumParameter"/> <Parameter name="Is64Bit" value="False" xsi:type="BooleanParameter"/> </Statement> -<Statement name="WriteScriptLogEntry" description="Write an Entry into the Procedure Log" continueOnFail="false"> <Parameter name="Comment" value="Page file set to System managed" xsi:type="StringParameter"/> </Statement> </Body> </Procedure> </ScriptExport>