The handle is invalid

  • vsa shared.JPG
    hi everyone:

    I am having the following problem while doing LAN WATCH.

    I get: "The handle is invalid" error

    background info: 10 days back I installed sysinternals from microsoft as I had installation problems of kaseya (to understand what the problem was). Kaseya is now installed and everything is working fine.

    latest problem: When I run LAN WATCH, and try to install agent on any "red colored machine", I get "The handle is invalid"

    Actually, all this is because of "PSEXEC.exe" present in the directory: D:\KASEYA6INSTALL\WebPages\ManagedFiles\VSASharedFiles

    if this ".exe" is not present, it will throw the following error message as atached:


    Please help

    Legacy Forum Name: The handle is invalid,
    Legacy Posted By Username: rajendra
  • I'm receiving the same message when I try to install the agent to some workstations. I was able to install a different agent to a server without any problems though. Could it be a login issue? We are currently in a workgroup environment.

    Thanks.

    Legacy Forum Name: How-To,
    Legacy Posted By Username: Jon.Wheeler
  • Handle is Invalid error.JPG
    First of all does the kaseya server need psexec.exe file to be present in shared files to perform LAN watch and push agents ?

    If it requires, then why don't they include in their hot fix. Hope Kaseya engineers are monitoring this forum and get the message.

    Not knowing what to do, I completely wiped out the Kserver, OS and everything. Started with a backed up OS image and fresh install of SQL and fresh downloaded install of Kaseya.

    Again ran Lan Watch still throws the same error. Totaaly clueless of what is going on here.

    I get the following error on a fresh install of Kaseya Server. When ever I run LAN WATCH, and try to push an agent through the default package and after giving domain admin credentials, it simply throws the below error.

    Please help this is a production server

    Till yesterday May 11 and 12 2010 this is what I have done:

    1. As I got this error becuase of installation of Sysinternals, I included "PSEXEC.exe" in the VSA shared folder
    2. Ran the LAN watch-- it throws "Handle is Invalid" error. Also attached the screen shot.

    This is what I have done today May 13 2010:

    1. Fresh Install of Win2k3 OS (only OS image and least system requirements were backed up and restored) SQL 2008 developer edition (all patches,updates,hotfixes etc)
    2. No NOD32 or any other antivirus s/w
    3. No installation of SYSINTERNALS (that includes psexec.exe etc) on the new system
    4. fresh download and Install of Kaseya 6 only today
    5. I run LAN Watch and try to install agents, it throws below error:

    If I do not include psexec.exe in the VSA Shared folder the following is error:

    Third party application has to be included in VSA shared folder and it prompts me to download from a microsoft link.

    If I include the following is the error:

    Error: Handle is Invalid --------> If I include Psexec.exe in the VSA Shared folder

    ConfusedSadConfusedMad

    Attached screen shots for the same


    I have tried running LAN Watch on another machine also but the same problem is re-occuring.

    I followed this KB article:::: http://portalgc.knowledgebase.net/article.aspx?article=270445&p=11855

    I now understand that Kaseya requires: psexec file but it throws the same error

    Able to install the agent manually through command line. But this is not what we want

    Thanks and regards,
    Rajendra

    Legacy Forum Name: How-To,
    Legacy Posted By Username: rajendra
  • psexec error.JPG
    Attachment refers to previous post.

    Legacy Forum Name: ,
    Legacy Posted By Username: rajendra
  • We were able to install the agents. We had a few issues so I'm not sure which one caused the message.

    The client is using a proxy server, they are also in a workgroup without a common admin level account. When we disabled the proxy and installed the agent with their account, it worked. We then re-enabled the proxy.

    We will preform some tests on the proxy as we push more agents.

    Hope this helps.

    Jon

    Legacy Forum Name: How-To,
    Legacy Posted By Username: Jon.Wheeler
  • fixed myself by disabling NOD32 on the machine where LAN watch was performed. It was blocking the scripts.

    Please note: In the earlier port I said there was no NOD32 on the server NOT on the machine where LAN watch ran. Here I had to disable NOD32 on the machine where LAN watch was performed

    Thanks
    raj

    Legacy Forum Name: How-To,
    Legacy Posted By Username: rajendra