Kaseya Community

SD email reader failing without error

This question is not answered

Hi All,

this is probably a longshot but i am going to try anyway to see if anybody has an idea.

Since this morning our Kserver - SD Email reader is not working well.

i don't have any error messages on the email readers, there are emails in the mailbox, they are not being pulled onto the Kserver (the don't show in kaseya\maillog directory)

i can telnet <mailserver> 110 and run POP3 commands wihtout any problem from our K server to our mailserver

the mailserver is exchange 2010 (with all HF's loaded)

 

on the exchange server i don;t get any errors, what i do see is our Kserver opening a POP3 session at every poll attempt but it doesn't close them

pulling the email to a pop3 client (on our kserver) works fine

 

i am clue less, any suggestions? (yes i also opened a support ticket for this)

thanks

All Replies
  • Hi Hans,

    I've been sitting with the same issue since Tuesday evening 23:00. Ticket logged with Kaseya but still no resolution yet.

  • Hi Thinus,

    can you try this and let me know if this works for you?

    open your SD email box with outlook

    create a new folder "old mails" for email (not under inbox)

    move all emails from the inbox to the newly created "old mails" folder

    send a test email to your SD and see if it comes in !

    this can be caused by a email that cannot be processed correctly by the email reader.

    let me know !

  • Hi Hans,

    That was the very first thing I tried but it didn't work. We had a similar issue previously where we actually had an error next to the email reader and this resolved the issue. This time there is no error and when you force it to poll it doesn't even try to poll.

  • did you try to disable and re-enable the readers on the General Tab?

    delete and recreate the email reader itself?

    re-aply schema? reboot the kserver?

  • Yes.......did all of those. Outbound working fine. Can telnet to pop3 account from Kaseya server using port 110 without any issues

  • strange, have you tried if IMAP works?

  • Still on SD 1.2 so we can only do POP3. The POP3 account works 100% on my Test Server, on the Production Server nothing happens.

  • Hi Just to jump on the band wagon here, Our email reader also fails with no error as of 2pm today. I have a ticket logged with kaseya and wait with bated breathed.

    I've exhausted my troubleshooting knowledge.

    1.) Restarted our exchange server x3

    2.) Restarted the k2 database and app server

    3.) Added a email client on the app server, and it popped the mail fine.

    4.) ping our exchange from both app and db server, with good responses.

    5.) telnet into our exchange from app server.

    6.) Re-apply scheme on k2 installation.

    7.) disabled and enabled the readers.

    So weird that its not even trying to poll. I have found dodgy errors in the logs, but I dont understand them.

    Oh well, Will post back once We have a fix.

  • @Leeroy: are you on SD1.2 or SD1.3 ?

  • @ Leeroy, did you also try the steps mentioned above ?

  • @ Thinus, is there a reason not to upgrade to SD1.3 for you?

  • @Hans, we still on SD1.2 - I have also tried your steps regarding the mailbox folder. Thats one of the techniques I'm quite familiar with lol, It being PoP and all.

  • @Leeroy, why not update and see if that does the trick for you?

  • Im dying to update to 1.3 and use the Imap,  but company policy requires me to do all Major updates on a Dev server first, and my dev server is still "under construction"

    Hans have you had any feedback from Kaseya support, I see you logged your ticket friday sometime.



    [edited by: Leeroy Stander at 8:49 AM (GMT -7) on 6-20-2011] *edit
  • well our email reader is fine again, we had a "nasty" email sitting in the mailbox. But support suspected a problem with the IMAP protocol and since you guys are on 1.2 that cannot be the same issue...sorry about that