How to Re-enable SQL Authnetication

If you recently applied a security patch or changed management settings on your SQL server, SQL authentication mode may have been disabled in SQL Server

If you have the SQL Server Enterprise Manager enable SQL Server authentication as follows:
1.
Open the SQL Server Enterprise Manager.
2.
Expand the SQL server group.
3.
Right-click on the server with your ksubscribers database and click Properties.
4.
On the Security tab, under Authentication, click SQL Server and Windows.
5.
Click OK and try logging onto your VSA again.


If you do NOT have access toSQL Server Enterprise Manager (not a part of MSDE version, but can be installed and used with MSDE if you have SQL Server CD) you may
reinstall the VSA as follows:
1.Locate the latest VSA database backup and copy it to a temporary directory. (The database backup is typically located in e.g.: C:\Kaseya\UserProfiles\@dbBackup\ksubscribers_db_200304071958.BAK
)
2.
Open the control panel andopen Add/Remove Programs.
3.
Select Kaseya Virtual System Administrator and click Change/Remove.
4.
When asked "Do you want to save the Kaseya user data?", click No
5.
Reinstall the Kaseya Virtual System Administrator.
6.
Restore the database from the saved backup. (System Tab -Configure - Restore... button)


NOTE: You must completely uninstall MSDE if you do not have SQL Server Enterprise Manager or Equivalent.
Reinstalling is the only way to enable SQL authentication.

Further information can be found on the Kaseya web site at:
http://www.kaseya.com/kforum/view_topic.php?id=23&forum_id=7



Legacy Forum Name: VSA failed to connect to the database,
Legacy Posted By Username: raybarber