Kaseya Community

Ticket e-mail format causing POP3 time-out?

  • I recently noticed that the email reader in tickets was not pulling in any new mail. I'm trying to figure out why. The incoming e-mail goes to my Exchange server, and I've enabled the Exchange POP3 service so that Kaseya can get the mail from there. This used to work fine but it stopped working on or about January 2. I am also unable to retrieve mail from this mailbox using other POP3 clients (Outlook, Outlook Express). The error message indicates a time-out. However, I am able to telnet into the Exchange server on Port 110 and list / retrieve all the messages that way.

    I manually deleted the oldest couple of messages and tried Outlook Express again. This time it retrieved one message but then timed out again. Then I manually deleted a couple more, but this time OE still couldn't read any messages.

    Could there be something about the format of these messages that is making POP clients choke? Any other ideas?


    Legacy Forum Name: Ticket e-mail format causing POP3 time-out?,
    Legacy Posted By Username: David_Schrag
  • Follow-up: I ended up manually deleting ALL of the messages in the mailbox and now the e-mail reader is able to pull in mail again. So there must have been some corrupt message in the queue that was causing the whole thing to fail. Therefore, my real concern is what I raised in a different post: I need an alert telling me that the e-mail reader process failed.

    Legacy Forum Name: Server,
    Legacy Posted By Username: David_Schrag
  • Update: I received a new email reader executable from Kaseya support, and that seems to have solved the problem. So if anyone else is having this problem you should contact support and ask for a new version of this file.

    Legacy Forum Name: Server,
    Legacy Posted By Username: David_Schrag
  • A hotfix has been posted with this updated KEmailReader, which handles more a few more variations of malformed content. Systems will automatically receive the update the next time "Refresh Patch Database" runs.

    Legacy Forum Name: Server,
    Legacy Posted By Username: PWong
  • Can you remind us how to check to see whether a fix like this has been successfully installed? Is it logged someplace?

    Legacy Forum Name: Server,
    Legacy Posted By Username: David_Schrag
  • One thing that does NOT seem to be fixed in the new e-mail reader is a formatting problem. I have one client using Eudora, and something is not working right when interpreting the HTML codes. The ticket comes through like this:



    David,


    Thanks a lot,


    Everything seems to work, and we've changed her password.


    George


    At 11:45 AM 1/25/2006, you wrote:



    When that same messages comes to me in Outlook (forwarded by my Exchange server), it looks just fine.



    Legacy Forum Name: Server,
    Legacy Posted By Username: David_Schrag