Kaseya Community

"High SQL Utiliation" message

  • Is there a way to increase the threshold on the Kserverfor SQL CPU utilization message? Our database is located in a SQL cluster that rarely sees CPU utilization under the 20% mark. The problem occurs when check-ins are deferred due to the high CPU utilization on the SQL server.



    Note: performance is not an issue, as our cluster can handle the load, it seems to be a setting in the Kserver that triggers at the 20% mark, deferring the agents from checking in. I don't remember if Kaseya recommends astandalone SQL server.




    Legacy Forum Name: "High SQL Utiliation" message,
    Legacy Posted By Username: bv_ciacob
  • Still hoping I can get an answer on this. Are there any plans to allow for Kserver administrators to change the value that defers check-ins?




    Legacy Forum Name: Server,
    Legacy Posted By Username: bv_ciacob
  • I'm afraid I don't have an answer but I'm seeing the same problem. We have quite a few clients that have that error message in their agent log and have not checked in since the failure.

    Legacy Forum Name: Server,
    Legacy Posted By Username: mcmonagle
  • We were getting (and are still getting this error.) I added a second Xeon 3.0 to our Kserver, and it seemed to help. However, there are still times during the day where offline machines process all their patch scans and scripts, and the CPU load spikes for several hours. Our CPU load is consistently around 35% (with about 900) clients, and it spikes from 50-65% during these times. Disk load is not a problem.

    This error causes our help desk to revert to using our old remote control system from time to time, as the agents don't seem to be picking up the remote control requests. Again, I added a second proc and this helped a lot, but it is still an inconvenience from roughly 9AM to 11AM.

    I don't anticipate that going to a four-way server will help greatly, as a lot of the Kaseya SQL queries are long and do not execute in parallel. I have tweaked the SQL server 2000 settings and disabled hyperthreading, which did help but not greatly. I haven't seen any reg keys or options in the .ini files to modify this value from 20 to a greater number.

    Not sure if there is any official comment from Kaseya, but one would be greatly appreciated.



    Legacy Forum Name: Server,
    Legacy Posted By Username: nzeigler
  • Here's an option, try changing the check-in frequency under "Agent" -> "Check-in Control." That should reduce the load on the server as the agents will not be chewing up the bandwidth pounding your Kaseya server.

    Legacy Forum Name: Server,
    Legacy Posted By Username: mcmonagle
  • I already added 50% to the length of the check-in frequency (however I can't do too much or remote control requests don't occur as quickly.) I also distributed the scripts across a greater time period.


    Legacy Forum Name: Server,
    Legacy Posted By Username: nzeigler
  • We had TONS of these problems, but only since we "upgraded" to SQL 2005 SP1 on our Kserver. Never had these problems with SQL 2000 SP4.

    I will note, however, that the 4.6.2 update seems to have quieted down the SQL utilization quite a bit (went from 24 houraverage of 70+% to 22%). Don't know if this was an undocumented fix (it wasn't in the changelog that I noticed).


    Legacy Forum Name: Server,
    Legacy Posted By Username: CFT-Rick
  • We're having same problem. It's having to pause and hold off on agents checking in due to "high cpu" despite the fact it's not really hitting the proc that hard. Changing the threshold would be great.

    Legacy Forum Name: Server,
    Legacy Posted By Username: RadicalSousa
  • Better yet, fix the underlying problem itself. With us averaging only 2 kb/sec of updates, this should NOT be slamming the SQL server like it is. Something is wrong with the db calls inside of Kaseya IMO.


    Legacy Forum Name: Server,
    Legacy Posted By Username: CFT-Rick