Kaseya Community

Lots of service timeouts for Kaseya Agent

  • We have our monitoring turned up pretty high in event logs, so. . . We've been seeing a LOT of timeouts for the Kaseya agent since moving to K2. Anyone else? I imagine many people may not be seeing this if they're not monitoring system logs on workstations, etc.

    This has only started since K2, and it appears to be only one the small handful of Windows 7 64 bit machines we have out there so far - and it's not on ALL of them either.

    Here's the text of the alerts -

    System log generated Error Event 7000 on agent For more information see http://www.eventid.net/display.asp?eventid=7000&source=Microsoft-Windows-Service Control Manager

    Log: System
    Type: Error
    Event: 7000
    Agent Time: 2010-04-13 15:11:31Z
    Event Time: 07:06:38 PM 13-Apr-2010 UTC
    Source: Microsoft-Windows-Service Control Manager
    Category: None
    Username: N/A
    Computer: computer
    Description: The Kaseya Agent service failed to start due to the following error:
    The service did not respond to the start or control request in a timely fashion.


    System log generated Error Event 7009 on agent For more information see http://www.eventid.net/display.asp?eventid=7009&source=Microsoft-Windows-Service Control Manager

    Log: System
    Type: Error
    Event: 7009
    Agent Time: 2010-04-13 15:11:31Z
    Event Time: 07:06:38 PM 13-Apr-2010 UTC
    Source: Microsoft-Windows-Service Control Manager
    Category: None
    Username: N/A
    Computer: computer
    Description: A timeout was reached (30000 milliseconds) while waiting for the Kaseya Agent service to connect.

    Legacy Forum Name: Lots of service timeouts for Kaseya Agent,
    Legacy Posted By Username: DiPersiaTech
  • Getting the same over here, only a reboot seems to help. I logged a support call. ps the affected machine's al have avg.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: noebas
  • I have also seen this. Apparently it has been fixed in agent 6.0.0.3. I upgraded all my agents earlier this week and have since had 1 agent go offline, although that seems to be a different error. Only time will tell

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: ChristiaanO
  • Am I missing something? I tried to force my clients to upgrade to the 6.0.0.3 version, but they only upgrade to 6.0.0.1 even if I select force upgrade.

    Thoughts? Help
    Jason

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: Sqwidd
  • Am I missing something? I tried to force my agents to upgrade to the 6.0.0.3 version, but they only upgrade to 6.0.0.1 even if I select force upgrade.

    Thoughts? Help
    Jason

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: Sqwidd
  • I had to download and update the agent files before updating the agents:
    http://download.kaseya.co.uk/agents/windows/kaseyawinagent_v6.zip

    1. Backup the original kAgentSilent.exe under \Kaseya\WebPages\ManagedFiles\VSAHiddenFiles\pcInstall on Kaseya server machine.
    2. Unzip the attached file and copy the new kAgentSilent.exe to \Kaseya\WebPages\ManagedFiles\VSAHiddenFiles\pcInstall folder.
    3. Open Kaseya admin web UI, select Update Agent from Agent tab, select the agent machines and check "Force update even if agent is at version 6.0.0.0" checkbox, then click on apply button to update the agents. You should see the agent version 6.0.0.3 once the update completed.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: ChristiaanO
  • Cool. I can handle that.

    Question tho...Why wouldn't that be done automatically from Kaseya (like thru hotfixes)?

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: Sqwidd
  • No idea, but my guess would be because this is an actual update and not a bug fix...but thats just a guess.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: ChristiaanO
  • Doing it now. . . We shall see. Thanks. Was on 6.0.0.2 previously.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: DiPersiaTech
  • ChristiaanO,

    Well, that's a handy link... We've had some trouble with mystery agent dropouts, maybe 6.0.0.3 will do the trick. Thanks!

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: GreyDuck
  • We had same problem and we were on 6.0.0.1. We upgraded and seemed to work. Thus may be a silly question, but why were we still on 6.0.0.1 when I had to learn about 6.0.0.3 from the forum and not automatically updated. Why could not kaseya send out an email stating if experiencing these problem please upgrade and give directions.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: gdoubinin
  • Nope, didn't work for us. I still have what appears to be only Win7 64 bit and Server 2008 64 bits dropping offline after the update to 6.0.0.3.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: DiPersiaTech
  • *sigh.

    This problem is realley getting on my nerves. I have a devloper looking into the situation and will update once I have news.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: ChristiaanO
  • ChristiaanO
    *sigh.

    This problem is realley getting on my nerves. I have a devloper looking into the situation and will update once I have news.



    Roger, thanks. Was dreading the thought of opening a ticket.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: DiPersiaTech
  • So any news?

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: DiPersiaTech