Kaseya Community

K2 SQL Server Reporting Services Setup

  • Hello all,

    I have went through the forum a few times trying various solutions people suggested but I just cannot get my setup to get off the ground. Here is a quick run down of our secondary server where i am testing the K2 install and going to be turning into production.

    The kaseya server is on a Win Server 2003 64bit Standard machine. A backup of our K2008 is currently installed and looks fine.

    The database is held on a separate Win Server 2008 64bit Standard with SQL Server 64 bit Web edition installed. The SQL Reporting Services is also installed.

    Like i mentioned the K2008 is doing fine so i started up the wizard to test run the K2 installation. I am at the screen asking for SQL Server Reporting Services URL and it is kicking my butt. I have tried everything i can think of but it should be http://SERVERNAME/ReportServer

    The SQL Server is on a SQL Workgroup and the Kaseya server is part of a domain. But, from the kaseya server i can browse out to the site through IE and it pulls up ok. Confused

    I have checked ports, firewalls and SQL Reporting Services permissions but nothing i do will let me past that screen asking for the URL. I have also tried putting in the IP address instead of Server name. I have a ticket in with Kaseya Support but it took them 5 days to just acknowledge my previous request; i know they are busy so thats why i'm asking for help.

    Everything is a fresh install from the OS up on the two machines and to my knowledge the Reporting Services is installed 64bit.

    Thanks for reading through my short story .

    Josh

    Legacy Forum Name: K2 SQL Server Reporting Services Setup,
    Legacy Posted By Username: jlewwwf
  • Well, i figured out my own problem after HOURS of trial and error. It had nothing to do with 64bit or even ports being opened. To best honest i'm not sure why this works but hopefully it will save someone a little bit of pain in the future.

    No matter what i put into that Reporting Services URL it came back as no good. so i went to the SQL Server and opened up the Security Logs under the event viewer. Here is where i found all of the login failure notices from my many attempts to connect with an event ID of 4625 and an error code of 0xc000006a. Google told me that meant that the user was correct but the password wasn't.

    Both of these servers were logging in to the local Administrator account but we were using different passwords for different servers. So, i just changed the administrator password on the Kaseya server and put in the URL again and it passed me right along. I really can't say why this works, but i am now moving right along with the K2 upgrade.

    Hope this helps someone.

    Josh

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: jlewwwf
  • Exactly what I was looking for.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: burgher