VNC and Win7

  • OK, tried the support route, but no one there seems to be able to understand our issue.

    We are all running windows 7, and we are consistently having problems connecting to other PC's (WinXP, Vista and Win7) with VNC. It doesn't matter what we're trying to connect to, if we're using VNC it fails. RDP Connections work fine.

    Looking at the log window that pops up gives us this error:

    [INDENT]Failed to create the process to run vncviewer.exe listen=1 AutoSelect=false LowColourLevel=1 FullColour=0.
    Successfully connected to the VSA server at xxx.xx.xxx.xxx:5721.
    Starting a 5 minute wait for a response from the relay client that is initiating the connection for this remote control session...Done.
    Connecting to the remote control application VNCviewer.exe on this machine.....Retrying......Failed.
    This relay client failed to connect to VNCviewer.exe locally on port 5500.
    This relay client will exit now...
    [/INDENT]

    our K server is in trusted sites, security is set to low, and we're running compatability mode.

    We've cleared out the dll's in Windows\downloaded program files and the %temp% directory and forced them to reload

    We've disabled the firewall and security software (some of us run KES, some Microsoft Security Essentials), and we've put exceptions for the vncviewer file in both the firewall and the security software.

    And we still get this error.

    The error seems random, but once it starts it continues and I can'ts eem to get rid of it.

    What am I missing?

    Legacy Forum Name: VNC and Win7,
    Legacy Posted By Username: rbjsea
  • I'm able to use K-VNC to connect to Win7 machines without issue.

    Are you using K-VNC or WinVNC? WinVNC supposedly doesn't, work, though you shouldn't be getting this error, because Kaseya won't even give you the option of using WinVNC.

    We previously had a similar error with an XP machine running with McAfee.

    Yes, it was the firewall, and before you give up on this thought, consider this:

    The fix wasn't to add VNC to the white list, it was to add the Agent (kausrtask I think it was called, it stood out) to the white list. Seems some firewalls will only let the Agent call out (which is fine for many tasks) but not accept an incoming connection (which VNC uses).

    Try that. If you're in the same boat we were, you don't even have to add a new exception, just update the exception for the Agent to allow traffic both ways.

    I'm not certain why this works, maybe something to do with the way Kaseya gets around NAT/PAT.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: dwujcik
  • Thanks for the reply - so some more info:

    [INDENT]
    dwujcik
    I'm able to use K-VNC to connect to Win7 machines without issue.
    [/INDENT]

    Yeah, it's not that we can't connect TO a Win7 machine; it's that we're running Win7 and can't connect to anything via WinVNC or K-VNC with our Win7 PC's. Looking at the errors, it sure looks to be something on our local machines.

    [INDENT]
    dwujcik
    Are you using K-VNC or WinVNC? WinVNC supposedly doesn't, work, though you shouldn't be getting this error, because Kaseya won't even give you the option of using WinVNC.
    [/INDENT]

    Yes, thanks - I got those backwards, thinking it was K-VNC that had the vista issue. either way, we can't use either to connect.

    [INDENT]
    dwujcik
    The fix wasn't to add VNC to the white list, it was to add the Agent (kausrtask I think it was called, it stood out) to the white list. Seems some firewalls will only let the Agent call out (which is fine for many tasks) but not accept an incoming connection (which VNC uses).
    [/INDENT]

    We've tried without the firewall at all, so I don't think that's the issue - tried the exceptions on the .exe I knew about, but just in case we also tried it with no firewall at all. You'd think disabled means *disabled* but maybe not? Smile

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: rbjsea
  • That's even more confusing. After a day in the field I remote from my Win7 machine at home to my Vista machine at work to fill in time sheets (CW doesn't like my home computer).

    Try uninstalling remote control and then installing K-VNC, and make sure it's set in Remote Control. I don't know if you can use K-VNC viewer to connect to WinVNC server, but if it does work there's bound to be a glitch somewhere.

    The next thing I can think of is to switch off the security software completely and try to connect. Remember to test both viewer and server sides for this.



    If you still can't connect, try scrubbing all traces of VNC software, from both file system and registry, and reinstalling. Failing that, try manually installing a VNC application and see if you can connect directly without Kaseya.

    Another thought just occurred, does your router/gateway support SPI? It's possible you have an intelligent firewall/router that's blocking the VNC packets because, well, it's remote control software.

    Does this happen on every machine on a site, or only some machines? Can you connect to the same machines from non-7 machines with VNC?

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: dwujcik
  • Warning: Off topic response...

    dwujcik: I had to run CW in XP compatibility mode and force it to use the IE8 32bit for it to work somewhat properly... and even then CW has issues with IE8 (I've noticed some with this forum as well)

    As for the (K)VNC thing, sorry I can't be of help on this we haven't seen any Win7 machines outside of our shop, and unfortunatlly we don't use Kaseya to connect to our work machines.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: thirteentwenty
  • Hmm, weird. Yeah, all of our in-house PC's are on Win7 64-bit. I haven't tried IE 32-bit but that might be worth it.

    Ther's got to be something else I need to delete or configure.

    Funny, I haven't had a single problem with CW! Added our main domain into compatability mode, and in the truseted sites, and it's worked great. Go figure.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: rbjsea
  • I ran into the same issue last night and was finally able to get it to work by going to manage add-ons and removing the kasRmtHlp Class and then attempting it again and it reinstalled the activex control. Im not sure if the cause was related to a msft update or avg update as they both happened on my systems right before I rebooted and lost functionality.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: adaptivetechgroup
  • Try starting IE as Administrator, log in to Kaseya and start a K-VNC session.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: patrickvs
  • patrickvs
    Try starting IE as Administrator, log in to Kaseya and start a K-VNC session.


    That brings up something I completely overlooked.

    Are you running Kaseya in IE or in a Mozilla client? I run entirely in Mozilla, and because of that I'm not using the ActiveX controls that Kaseya normally uses to start remote control. This results in an executable that spawns the viewer and calls the server.

    Maybe try cutting ActiveX out of the picture? Either use a Mozilla-based browser, or disable ActiveX for your Kaseya interface, either way should get you the downloaded file. See if that works, and let us know! As a die-hard IE-Hater I've never even tried Kaseya in IE, so I don't know how it'll behave.

    (And before anyone asks, my hatred of IE goes back really far, and no, I'm not interested in finding out if that hatred is still justified because Firefox works just fine.)

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: dwujcik